[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: No Sound after Experiment with KDE4

Kent West wrote:
I had a perfectly working Debian Sid/KDE3 box.

Then I added experimental to my sources.list file and installed enough KDE4 stuff to play with it for a day or so. If I recall correctly, sound worked for the first few hours, but by the time I got tired of KDE4, I noticed sound was no longer working.

I uninstalled all the KDE4 stuff, and reinstalled KDE3. Still no sound (either in KDE, or Gnome, or Icewm, or via mplayer with no X/DE running).

I upgraded my kernel (from 2.6.22, I think, to 2.6.28-1-686. Still, no sound.

I did a dist-upgrade. Still, no sound.

I uninstalled/tweaked/reinstalled stuff like linux-sound-base, any alsa-related stuff, manually installed modules, etc. Still, no sound.

It LOOKS like everything is working:

westk@canuhold:~$ cat /proc/asound/cards
0 [I82801DBICH4   ]: ICH4 - Intel 82801DB-ICH4
                     Intel 82801DB-ICH4 with AD1981A at irq 17

and any players I fire up look like they're working (progress bars move; video effects jiggle; etc). I've played with Kmix and alsamixer to make sure all the channels are unmuted and volume up. Still, no sound.

I can boot off a year-old XUbuntu CD, and sound works fine.

I compared the modules loaded by Xubuntu and copied over some /etc/modprobe.d files, and I'm still getting the same behavior: everything looks like it works, but no audio is produced (it's like the sound is muted, but it's not).

The one thing I noticed as different is that "cat /proc/asound/cards" while under Xubuntu gave the second line (compare to that above) as:

Intel 82801DB-ICH4 with AD1981A at 0xffa10400, irq 21

But I still don't know where to go from here. Any suggestions?


Kent West        <")))><

Reply to: