[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

why /sys cannot be copied?

The matter is like this: My debian sid in /dev/sda4 was broken this
morning, so I installed a new debian system in a new partition
/dev/sda3, and in the new system, i run /sbin/e2fsck -C 0 -y -c -c
/dev/hda4 to repair the broken system, and it works, after repair, I
can view the content of /dev/sda4, but when i try to boot system by
/dev/sda4, it says:
mount: mounting /sys on /root/sys failed: Invalid argument
run-init: /sbin/init: No such file or directory
and i fount that the /sys in the broken system is a shell file, but
the /sys in the new system is a folder, so i tried to copy the sys
folder from new system to broken system, by cp /sys /root/OldRoot/sys,
but it says many files in the new sys folder cannot be read! why? how
could I resove the "mount: mounting /sys on /root/sys failed: Invalid
argument" problem?
also the "run-init: /sbin/init: No such file or directory" problem? thanks

Reply to: