[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Kernel issues: booting from USB storage


Just to give a little background, after 3 years of running Gentoo (and SuSE previously,) I have given up due to the impossible maintenance burden and am migrating back to a binary distribution. Having sworn off RPMs for life, I have chosen Debian as the most mature and mainstream distro.

To minimise disruption, I have been doing the installation on a new and larger hard disc connected to the machine (ThinkPad Z61m) via a USB-to-SATA adapter. Most of the software installation I have done so far was done chrooted from my Gentoo system.

All has gone well so far, but I am experiencing issues trying to boot the external disc with anything but the Debian stock kernel. Here are the facts:

* I am booting from Grub on the internal disc.

* With the Debian kernel, the external disc boots fine.

* I cannot use the stock kernel for long as, due to poor hardware design, this machine needs the THINKPAD_ACPI kernel module so that I can manually run the fan at full speed. (Otherwise I get lockups.)

* I have a requirement to use 2.6.24-r7 (this is the kernel for which the latest stable realtime patches are available.)

* Whilst I have configured the kernel with SCSI, SATA and USB Mass-storage compiled in, /dev/sdb2 (which works with the Debian kernel) cannot be found. It can, however, see the partitions on the internal SATA disc.

* An attempt at using the kernel with initrd (using kernel-package) got the boot a little further along but this time it froze at the point that is said it was connecting to sdb.

* I have copied my (working) Gentoo kernel configuration over, built and installed and still get the device not found error.

In case it is of any help, here are the outputs of lspci and the contents of /proc/bus/usb/devices, when booted with the Debian stock kernel:

...and the .config of the kernel which works not:
(Think that's my latest one, tried so many times!)

In a word, help! I've never had an issue like this before except when I've forgotten to include an essential kernel module - but I can't see what I could have missed. (Then again, I've never tried booting from an external device before - but the stock kernel can do it!)



Matthew Smith
Smiffytech - Technology Consulting & Web Application Development
Business:      http://www.smiffytech.com/
Blog/personal: http://www.smiffysplace.com/
LinkedIn:      http://www.linkedin.com/in/smiffy
Skype:         msmiffy
Twitter:       @smiffytech

Reply to: