[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Strange keyboard lag

I've got a fresh install of Debian Lenny on a brand new Fujitsu
Siemens Esprimo machine.
Everything works flawlessly except from strange behavior from my keyboard.

Inn tty[1-6] when I type, sometimes 1 keystroke results in several
letters, e.g. I type 'ls' and the terminal show 'llllls' .
In X things seem to be a bit different, at least I don't get several
letters for 1 keystroke, but if I for instance want to use my arrow
keys to move several positions to left, right, up or down by holding
down one of the arrow keys there seem to be some kind of lag. When I
press and hold the arrow key the cursor moves 3-4 positions and then
it stops, if I keep holding the arrow key after some seconds it starts
moving again.
There's no logic in how many times the cursor moves from the first
time I press and hold the arrow key, it could be 3-4 positions, or it
could be 20, but it always stops after a short while, and then it
moves a bit again. Very lag'y .

I've seen the same behavior once before, 5-6 years ago, where the
keyboard behaved something like this. Then it turned out to be a buggy
module connected to my wifi card (I think).

I got no wifi card on this machine, but the motherboard has no ps/2
connectors, so keyboard and mouse is connected via usb which now is my
primary suspect, but I'm a bit at lost in howto figure out if usb is
the problem (how to test it). I google'd up a forum where somebody
talked about enable'ing 'ps/2 emulating for usb keyboards' in bios,
but my motherboard has no such setting either.

Ssh'ing to the problem machine from an other computer shows no such behavior.
Ssh'ing from the problem machine to any other machine does show the
same behavior.

I've tried switching usb ports for keyboard and mouse, without success.
I've connected the keyboard to an other computer and confirmed that it
worked ok on that computer.

I suspect there might be an issue with the usb controller, which is an
nVidia Corporation GeForce 7100/nForce 630i (rev a1) controller, but
my colleague runs Ubuntu 8.04 LTS, kernel 2.6.24 without these
problems on the exact same machine...
I'm running generic Lenny kernel 2.6.26-1-amd64

I've attached output of 'lspci -vv' , 'lsusb -vv', dmesg +
/proc/interrupts if anyone got any hints in how I can troubleshoot
this problem I highly appreciate your opinion :)

Joar Jegleim

Reply to: