[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: /dev/sndstat

On 01/12/09 03:44, M. Lewis wrote:

M. Lewis wrote:
M. Lewis wrote:

Ron Johnson wrote:
On 01/11/09 23:33, M. Lewis wrote:
Ron Johnson wrote:
On 01/11/09 22:34, M. Lewis wrote:
Ron Johnson wrote:
On 01/11/09 21:55, M. Lewis wrote:
moe:~# lspci -v -s14.2
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
        Subsystem: Giga-byte Technology Device a002
        Flags: slow devsel, IRQ 16
        Memory at fe024000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
        Kernel modules: snd-hda-intel

Do you happen to know what that fast devsel / slow devsel business is about?


What happens when you:
# depmod
# modprobe -v snd_hda_intel snd_seq

Well, actually that works with speaker-test. *BUT*, I'm not holding my breath. I've had it this far before and couldn't reproduce it again.

Let me reboot and try again before I pronounce it 'fixed'.

Well, no, but more information:

install /sbin/modprobe --ignore-install snd-hda-intel snd_seq && /lib/alsa/modprobe-post-install snd-hda-intel insmod /lib/modules/2.6.26-1-amd64/kernel/sound/pci/hda/snd-hda-intel.ko snd_seq FATAL: Error inserting snd_hda_intel (/lib/modules/2.6.26-1-amd64/kernel/sound/pci/hda/snd-hda-intel.ko): Unknown symbol in module, or unknown parameter (see dmesg)
FATAL: Error running install command for snd_hda_intel

And from dmesg:

[  362.587129] snd_hda_intel: Unknown parameter `snd_seq'

I will try it without the snd_seq.

Still no luck without the snd_seq or even putting snd_seq in a separate modprobe:

modprobe -v snd_seq
modprobe -v snd-hda-intel

So the depmod/modprobe worked, but then you rebooted and now it doesn't work????

Ron Johnson, Jr.
Jefferson LA  USA

"I am not surprised, for we live long and are celebrated poopers."

Reply to: