[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: apt-get cannot conect to server

On Sat, 03 Jan 2009 15:33:36 -0200, oxy wrote:

> I changed /etc/apt/sources.list and got the followihg:
> # apt-get update
> Get:1 http://http.us.debian.org etch Release.gpg [386B] Hit
> http://http.us.debian.org etch Release Ign http://http.us.debian.org
> etch/main Packages/DiffIndex Hit ftp://ftp.us.debian.org testing
> Release.gpg Ign http://http.us.debian.org etch/contrib
> Packages/DiffIndex Ign http://http.us.debian.org etch/non-free
> Packages/DiffIndex Hit http://http.us.debian.org etch/main Packages Hit
> ftp://ftp.us.debian.org testing Release Hit http://http.us.debian.org
> etch/contrib Packages Hit http://http.us.debian.org etch/non-free
> Packages Hit ftp://ftp.us.debian.org testing/main Packages/DiffIndex Hit
> ftp://ftp.us.debian.org testing/contrib Packages/DiffIndex Hit
> ftp://ftp.us.debian.org testing/non-free Packages/DiffIndex Fetched 1B
> in 4s (0B/s)
> Reading package lists... Error!
> E: Dynamic MMap ran out of room

You may need to look at /etc/apt.conf Apt::Cache-Limit 
But if you clear up your sources.list you probably are fine:
http://http.us.debian.org etch/
ftp://ftp.us.debian.org testing/
use just one of these.

> E: Error occurred while processing tkusr (NewVersion1) E: Problem with
> MergeList
> /var/lib/apt/lists/http.us.debian.org_debian_dists_etch_main_binary-
> E: The package lists or status file could not be parsed or opened.
> I tried
>      rm /var/lib/apt/lists/lock /var/lib/apt/lists/partial/*
>      (dont know what they do).

Now that is what I call an adventures attitude.

>           # apt-get update
>           Err http://http.us.debian.org etch Release.gpg
>             Could not connect to http.us.debian.org:80 (,
> connection timed out
> bUt i believe there is a specific problem
> to be addressed.

I think so too. Please give some info on your dns. What is in /etc/
resolv.conf? Have your tried the suggestion of using another dns server?
Do you have dnsmasque installed? DHCP/dns from a (cheap) router?

Have fun!

Reply to: