[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: what error openning V4L means

On Fri, Jan 2, 2009 at 5:57 PM, Abdelkader Belahcene
<abelahcene@gmail.com> wrote:
> Hi,
> I installed  spcagui and gpsca  for using  webcam, I got the error on
> V4l, what it does it mesn
> bela@belaptop:/usr/src/linux$ spcagui
> SpcaGui version: 0.3.5 date: 18 September 2005
> video device /dev/video0
> ERROR opening V4L interface
> : No such file or directory

I have a similar problem with my old webcam (Webcam Go Plus by
Creative. I was surprised to see it's supported in GNU/Linux!:

I followed the instructions in:

Created the node:
mknod /dev/video0 c 81 0
chmod 666 /dev/video0

daniel@localhost:~$ ls -l /dev/video0
crw-rw-rw- 1 root root 81, 0 2009-01-02 17:17 /dev/video0

Finally, I installed xawtv and came, but both display the same error message.
This is camE's output for example:

daniel@localhost:~$ camE
camE: camE 1.9 - (c) 1999, 2000 Gerd Knorr, Tom Gilbert
camE: grabber config: size 320x240, input 0, norm 0, jpeg quality 75
can't load font FreeSans/8
can't load font FreeSans/8
open /dev/video0: No such device

Someone in another list suggested that I delete that node and install gspca.

So I ran:

localhost:~# rm /dev/video0
localhost:~# apt-get install gspca-modules-2.6-686

but camE keeps complaining with the same error message. I installes
camorama, and the problem persists.

lsbus lists the camera.

I find it funny that the programs complain that they don't find
/dev/video0, even after I created it.

Reply to: