[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

grub2 and ext4

turns out the issue is ext4 which doesn't work with grub, but it does with
grub2. The problem is that the kernel seems to miss read the partition.

I setup another partition to rescue my system so now I have
sda1: ext4 - original system
sda5: ext3 - small rescue system

grub2 installed on both (current is suppoesed to boot from sda1)

if I set in grub
set root=(hd0,5)
linux /boot/vmlinuz-2.6.28 root=/dev/sda1 ro

everything works fine

If I set
set root=(hd0,1)
linux /boot/vmlinuz-2.6.28 root=/dev/sda1 ro

I get a kernel panic: couldn't load root file system tried: xfs

any idea on how I can get the kernel to recognize that it has ext4 file system
so that I can dump the rescue partition (i.e make the first option work)?


On Thu, 1 Jan 2009 13:22:32 +0200
Micha Feigin <michf@post.tau.ac.il> wrote:

> After the last update grub started booting into the command line (shows
> grub> ) and seems to ignore menu.lst. I managed to boot by setting
> kernel /boot/vmlinuz-2.6.28
> boot
> I then tried to reinstall the kernel hoping that it would fix grub but now
> when I try the same method to boot I get the error
> Invalid or unsupported executable format
> The drive is formated to ext4. grub worked after that but maybe the kernel was
> written in a different method now?
> any ideas?
> thanks

Reply to: