[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: unbootable system after fresh 4.0r5 installation

Boyd Stephen Smith Jr. --> debian-user (2008-12-08 16:46:46 -0600):
> http://reactivated.net/writing_udev_rules.html

Thanks, udev(7) is probably what I was looking for.

I tried two approaches:

  1) Using built-in persistent symlinks (/dev/disk/...).
  2) Writing custom rules to create symlinks to the desired file system
     block devices.

I then used those symlinks in /etc/fstab and /boot/grub/menu.lst

While 1) worked fine, I noticed a problem with 2): passing the symlink
to the root file system as the root= kernel option doesn't work ("ALERT!
/dev/root doesn not exist"...).  I guess this makes sense since my
custom rule which defines the root file system symlink is in a file on
the root file system (/etc/udev/rules.d/010_local.rules)...  But why
does 1) work then?  The symlinks I use (/dev/disk/by-id/scsi-XXX-partN)
seem to be defined in /etc/udev/persistent.rules, i.e. also on the root
file system:

KERNEL=="sd*[!0-9]|dasd[!0-9]*|sr*",    ENV{ID_SERIAL}=="?*", \
KERNEL=="sd*[0-9]|dasd*[0-9]",          ENV{ID_SERIAL}=="?*", \

Any hints?

Regards, Jukka

bashian roulette:
$ ((RANDOM%6)) || rm -rf ~

Reply to: