[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: gui unreadable after bad shutdown

On Wed, 2008-12-03 at 23:08 -0600, Kent West wrote:
administrator wrote:
> My system fails to start properly after a bad shutdown (not using
> shutdown/power cut), the graphics are incorrect and full of lines at
> login point. No way of reading the screen as no real images to see, the
> initial boot text is fine but on entry into GUI it all goes wrong. 
> This has happened before and sorted itself after waiting until the 21st
> boot to sort out file integrity but not now.  
> I have installed a new HD as master and re loaded the latest dvd
> download but still the same thing when previous HD ran as slave. Now  it
> has been 8 hrs trying to no avail, this is on i386, please advise, my
> work is in limbo until i sort this, TIA

I managed to work out that it was the graphics card!!
must have been fading out for a while
Funny that it was fixing itself before at the same time the boot did a
file integrity check before it failed

Thanks anyway

Try changing the res with Ctrl-Alt-plus-on-the-numpad a time or dozen. 
Any improvement?

You should be able to press Ctrl-Alt-F2 to get to the second Virtual 
Terminal (VT), and log in from there into a text-mode only setup.

 From there, you can start working to fix X.

I'd start by shutting down whatever login manager you have (sudo 
/etc/init.d/[x|k|g|w]dm stop). Then you can try starting X manually with 
"startx &". If that gives you a garbled screen, you can 
Ctrl-Alt-Backspace to kill it, then tinker with /etc/X11/xorg.conf, and 
try again.


Reply to: