[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Broken perl

On Sat, Nov 01, 2008 at 07:45:20PM +0100, Florian Kulzer wrote:
> > [...]
> > Errors were encountered while processing:
> > mono-gac
> > mono-runtime
> > libmono2.0-cil
> > libgconf2.0-cil
> > libmono-addins0.2-cil
> > libmono-system-web2.0-cil
> > libmono1.0-cil
> > libgnome2.0-cil
> > libmono-addins-gui0.2-cil
> I don't know mono so I cannot say much about this problem. It seems that
> the post-installation script looks for the files at the wrong locations:

Ok, thanks for the hint. That was the case indeed. However, I solved
it in another way: purging everything :-) It seems that the only
application that needed this mono stuff was tomboy, which I tried once
and don't use anyway. Not all unconfigured packages disappeared when
deinstalling tomboy, I had to purge them manually one by one, taking
care not to break anything, and eventually all the packages above
could be removed from my system. 

Now errors in my system have been reduce to one, only one:

Preparing to replace libcairo-perl 1.043-1 (using
.../libcairo-perl_1.060-1_i386.deb) ...
Unpacking replacement libcairo-perl ...
dpkg: error processing
/var/cache/apt/archives/libcairo-perl_1.060-1_i386.deb (--unpack):
 unable to make backup link of
./usr/share/doc/libcairo-perl/changelog.gz' before installing new
version: Operation not permitted
Errors were encountered while processing:
 E: Sub-process /usr/bin/dpkg returned an error code (1)
 A package failed to install.  Trying to recover:
Fortunately, this does not seem to block other packages upgrades, as
the original perl problem did, but it's still annoying.


Reply to: