[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: "This might mean you need to manually fix this package"

Wayne Topa wrote:
> H.S. wrote:
>> Hello,
>> I updated my Debian Testing machine this morning and noticed that I was
>> getting an error from dpkg. The cause was no space on /var. If I tried
>> to reinstall the package which was showing the problem I got this:
> i
> If I missed if you tried aptitude/apt-get autoclean I'm sorry, but that
> is the first thing I would try if I got the "no space on /var" message.

Yes, I agree. That helps sometimes (most times?), but in this situation
/var was 100% full and autoclean wasn't working. So what I did was:

- became root
- cd into /var/cache/apt
- moved archives directory to another partition (e.g. to /home/hs/tmp)
- created a link in /var/cache/apt:
$> ln -s /home/hs/tmp/archives .
- then tried 'aptitude autoclean'

But by this time gparted was being reported as really in bad shape. The
procedure I listed before apparently solved the problem.

Once everything was working
- deleted the archives link in /var/cache/apt
- moved archives directory back into /var/cache/apt from /home/hs/tmp


> WT

Reply to: