[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

ssh X11 forwarding problem

Ok from my local host I can ssh into a host on network A with 'ssh -X
foo@bar' and it works, I tested by running xeyes.
It automagically sets the DISPLAY to 'localhost:10.0' (it actually
shows the word localhost).

Now when I try the same thing on a host on network B with 'ssh -X
root@baz' it fails with:

Error: Can't open display

I checked the value of DISPLAY (echo $DISPLAY) after I ssh in and this
time it is set to nothing.

So I tried setting display to my local IP on various combinations and
they all fail with "Error: Can't open display ip:10.0", "Error: Can't
open display ip:0.0" etc..

So what is going on? Both hosts running Open SSH, I even disabled the
firewall on the host on network B and then I tried locally "xhost
+network-b-host-ip" to explicitly allow it and still no luck. I didn't
have to bother with any of this for it to with network A's host.

The X11 forwarding worked fine on host A (a school host) yet fails on
host B (my VPX box).

Any clue how I can fix this and why it works on network A's host but not on B's?


Reply to: