[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

no line numbers in backtrace in Testing


I recently noticed that on an updated Debian Testing machine if I used gdb to debug a program, the backtrace did not give me the source files and line numbers denoting the function calls.

I tried the same source at my university computer, running Hardy and the same version of gdb. There I got the line numbers as expected.

Hunting around google I noticed a post about a similar problem a few years ago and tried the proposed solution there: to install libc-dbg. So Installing that on my Debian machine (sudo aptitude install libc-dbg) fixed the problem.

Now, what is strange is that this package is not installed in the Hardy machine and gdb works okay there. Has something changed in Debian Testing in the last some weeks that would create this? Is libc-dbg really needed if one is to used gdb? If yes, how come it is not needed in Hardy? Just want to clear up this matter since this was not happening till approximately six weeks ago.

Here are some relevant packages I have in Debian Testing:
$> dpkg -l gdb libc* gcc* | grep ^i | gawk '{print $2 ,"  "  $3}; '
gcc   4:4.3.1-2
gcc-2.95   1:2.95.4-27
gcc-3.3   1:3.3.6-15
gcc-3.3-base   1:3.3.6-15
gcc-3.4-base   3.4.6-6
gcc-4.0   4.0.3-7
gcc-4.0-base   4.0.3-7
gcc-4.1   4.1.2-23
gcc-4.1-base   4.1.2-23
gcc-4.2   4.2.4-3
gcc-4.2-base   4.2.4-3
gcc-4.3   4.3.1-2
gcc-4.3-base   4.3.1-2
gdb   6.8-3
libc6   2.7-10
libc6-dbg   2.7-10
libc6-dev   2.7-10
libc6-i686   2.7-10
libcaca0   0.99.beta14-1
libcairo-perl   1.060-1
libcairo2   1.6.4-6
libcairo2-dev   1.6.4-6
libcairomm-1.0-1   1.6.0-1
libcamel1.2-11   2.22.3-1
libcamel1.2-8   1.6.3-5
libcanlock2   2b-4
libcap1   1:1.10-14
libcap2   2.10-3
libccid   1.3.8-1
libcddb2   1.2.1-1
libcdio-cdda0   0.78.2+dfsg1-3
libcdio-paranoia0   0.78.2+dfsg1-3
libcdio6   0.76-1
libcdio7   0.78.2+dfsg1-3
libcdk5   5.0.20060507-1
libcdparanoia0   3.10.0+debian-1
libchm1   2:0.39-9
libclass-accessor-perl   0.31-2
libcolorblind0   0.0.1-1
libcomerr2   1.41.0-3
libcompress-raw-zlib-perl   2.012-1
libcompress-zlib-perl   2.012-1
libconfig-file-perl   1.42-1
libconfig-inifiles-perl   2.39-5
libconsole   1:0.2.3dbs-65.1
libconvert-binhex-perl   1.119+pristine-3
libcpufreq0   004-2
libcroco3   0.6.1-2
libcrypt-ssleay-perl   0.57-1+b1
libcucul0   0.99.beta14-1
libcups2   1.3.7-9
libcups2-dev   1.3.7-9
libcupsimage2   1.3.7-9
libcupsys2   1.3.7-9
libcupsys2-dev   1.3.7-9
libcurl3   7.18.2-5
libcurl3-gnutls   7.18.2-5
libcv-dev   1.0.0-5
libcv1   1.0.0-5
libcvaux-dev   1.0.0-5
libcvaux1   1.0.0-5
libcvsservice0   4:3.5.9-2
libcwidget3   0.5.12-1

And here are some from the Hardy machine:
$> dpkg -l gdb libc* gcc* | grep ^i | gawk '{print $2 ,"  "  $3}; '
gcc   4:4.2.3-1ubuntu6
gcc-3.3-base   1:3.3.6-15ubuntu6
gcc-3.4   3.4.6-6ubuntu5
gcc-3.4-base   3.4.6-6ubuntu5
gcc-4.1   4.1.2-21ubuntu1
gcc-4.1-base   4.1.2-21ubuntu1
gcc-4.1-doc   4.1.2-21ubuntu1
gcc-4.2   4.2.3-2ubuntu7
gcc-4.2-base   4.2.3-2ubuntu7
gcc-4.2-doc   4.2.3-2ubuntu7
gcc-4.2-locales   4.2.3-2ubuntu7
gdb   6.8-1ubuntu2
libc6   2.7-10ubuntu3
libc6-dev   2.7-10ubuntu3
libc6-i686   2.7-10ubuntu3
libcaca0   0.99.beta13b-4
libcairo-perl   1.043-1
libcairo2   1.6.0-0ubuntu2
libcairo2-dev   1.6.0-0ubuntu2
libcairo2-doc   1.6.0-0ubuntu2
libcairomm-1.0-1   1.4.2-1
libcairomm-1.0-dev   1.4.2-1
libcamel1.2-11   2.22.3-0ubuntu1
libcap1   1:1.10-14build1
libcdio-cdda0   0.78.2+dfsg1-2ubuntu1
libcdio-paranoia0   0.78.2+dfsg1-2ubuntu1
libcdio7   0.78.2+dfsg1-2ubuntu1
libcdparanoia0   3.10+debian~pre0-6
libchromexvmc1   1:0.2.901-0ubuntu4
libchromexvmcpro1   1:0.2.901-0ubuntu4
libck-connector0   0.2.3-3ubuntu5
libcomerr2   1.40.8-2ubuntu2
libcommons-beanutils-java   1.8.0~beta-1
libcommons-beanutils-java-doc   1.8.0~beta-1
libcommons-collections-java   2.1.1-8
libcommons-collections3-java   3.1a-3.1
libcommons-collections3-java-doc   3.1a-3.1
libcommons-dbcp-java   1.2.2-1
libcommons-digester-java   1.8-1
libcommons-el-java   1.0-4
libcommons-launcher-java   1.1-3
libcommons-logging-java   1.1-1ubuntu1
libcommons-modeler-java   2.0.1-4
libcommons-net-java   1.4.1-1
libcommons-pool-java   1.3-1
libcompfaceg1   1:1.5.2-4
libcompizconfig0   0.7.4-0ubuntu1
libcompress-raw-zlib-perl   2.008-1
libcompress-zlib-perl   2.008-1
libconfig-inifiles-perl   2.39-2
libconsole   1:0.2.3dbs-65ubuntu7
libconvert-binhex-perl   1.119+pristine-2
libcroco3   0.6.1-1build2
libcrypt-ssleay-perl   0.55-1
libct3   0.63-3.2ubuntu1
libcucul0   0.99.beta13b-4
libcupsimage2   1.3.7-1ubuntu3
libcupsys2   1.3.7-1ubuntu3
libcupsys2-dev   1.3.7-1ubuntu3
libcurl3   7.18.0-1ubuntu2
libcurl3-gnutls   7.18.0-1ubuntu2
libcvsservice0   4:3.5.9-0ubuntu1
libcwidget3   0.5.8-1ubuntu1


Reply to: