[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: Can't reboot after update

This is so strange. Here's the email I started to write:
Thanks to all the folks who replied, both on and off the list. I'm
making some progress, but I'm still not out of the woods and still need

This system uses LILO 22.6.1. I wasn't able to use Tab to bring up the
menu, but holding down Shift before 'LILO...' appeared worked to bring
up the menu. I have two choices, 'Linux' and 'LinuxOLD'. I'm assuming
that I'm using 'Linux' normally, and so didn't try anything. Choosing
'LinuxOLD' causes the system to stop with these messages:
  VFS: Cannot open root device "802" unknown-block(8,2)
  Please append a correct "root=" boot option.
  Kernel panic-not syncing: VFS: unable to mount root fs on

I then tried to book again with 'boot: LinuxOLD root=/dev/sda2'. This
generates this version of the error messages:
  VFS: Cannot open root device "sda2" unknown-block(0,0)
  Please append a correct "root=" boot option.
  Kernel panic-not syncing: VFS: unable to mount root fs on

However, as I was writing this, I started to get diagnostic email
messages from this system. I realized that I walked away from this
server in our server room just after I started a normal reboot, thinking
that it would still stop at the same error. When I walked back to the
server room, I discovered that it seemed to have booted normally. I was
able to log on to the system. Typing 'uname -a' gave '2.6.18-6-686 #1
SMP Tue Jun 17 21:31:27 UTC...' which I think is correct for this new
version. I didn't change anything in /etc/lilo.conf, and didn't press
any buttons while it was booting.

This server has previously experienced intermittent hard disk backplane
voltage problems. Unfortunately, it's eight years old, and Dell doesn't
sell replacement parts for it anymore. I'm going to try to find one on
eBay sometime, but just haven't yet.

Thanks, again, to all the folks who helped me out and reminded me of the
steps to take to try to track down this problem. I don't think it's a
problem with Debian now, but rather a hardware problem.


-----Original Message-----
From: Zembower, Kevin [mailto:kzembowe@jhuccp.org] 
Sent: Tuesday, July 29, 2008 10:43 AM
To: debian-user@lists.debian.org
Subject: Can't reboot after update

I'm hoping someone can help me with this urgent problem. I just applied
the updates that became available in the last couple days to my Debian
etch host running on a Dell PowerEdge 2450 server. This included an
update to the kernel, so I rebooted the host. The host failed to
restart. The first error message on the console was '/init /init cannot
open /dev/root no such device.' Just before that, it said "mounting root
file system. Running /scripts/local-top." It finally ended by dropping
me into BusyBox, with which I'm not familiar.

There were no earlier indications of problems with the output to the
console. All the output concerning /dev/sda, where all my directories
are partitioned, seemed normal. This host uses a Dell PERC 3/Si card to
provide RAID-5.

Can anyone help me correct this problem? Any suggestions of commands to
run in BusyBox to either fix or diagnose this?

Thanks in advance for your help, advice and suggestions.


Kevin Zembower
Internet Services Group manager
Center for Communication Programs
Bloomberg School of Public Health
Johns Hopkins University
111 Market Place, Suite 310
Baltimore, Maryland  21202

To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org 
with a subject of "unsubscribe". Trouble? Contact

Reply to: