[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Issue with VMware


> So I installed VMware server, had to use the any-any update for I use the
> 2.6.24 kernel and
> when I try to run it, it says that same message as before running the
> vmware-conifig.pl tool.

I'm running about the same kernel (2.6.24-1-686).
I'm running also VMWare server rel. 1.0.5 (latest).
First i install VMWare Server with its installer (vmware-install.pl)
and then, when the installer fails creating modules, i use the
runme.pl included in vmware-any-any-update package (rel 116).

> I also tried VMware Workstation trial, and that didn't work either.
> I tried running vmware-config.pl after running the any-any update several
> times, and I get the same message.

Maybe posting error will help us.

Anyway, if you update often your system (as me), the problem you
encountered could be related to the current gcc version (different
from the one used to compile the kernel).
If so, you can recreate the link of /usr/bin/gcc to point to the right
gcc version, for example:

# ls -l /usr/bin/gcc*
lrwxrwxrwx 1 root root      7 2008-04-09 21:27 /usr/bin/gcc -> gcc-4.1
-rwxr-xr-x 1 root root  82064 2008-03-29 18:16 /usr/bin/gcc-3.4
-rwxr-xr-x 1 root root 195844 2008-03-10 00:10 /usr/bin/gcc-4.1
-rwxr-xr-x 1 root root 192252 2008-03-24 01:09 /usr/bin/gcc-4.2
-rwxr-xr-x 1 root root 207008 2008-04-02 05:04 /usr/bin/gcc-4.3

# rm /usr/bin/gcc
# ln -s /usr/bin/gcc-4.2 /usr/bin/gcc

(of course gcc version may be different).

...and the retry with the installer or with the any-any-update.
Or, better, you can force the use of a specific GCC version, but i
don't remember how do that in this case.

Hope it helps you.

Reply to: