[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Alsa Problems with new Etch



alan@patriot.net wrote:
On Thu, Mar 27, 2008 at 10:30:49AM -0400, alan@patriot.net wrote:


Alsa has gone through some changes. And though I'm no expert at all,
you should likely provide us with some additional information to help
you on the way. Please provide the output of

dpkg -l \*alsa\*

and

lsmod | grep snd

and the relevant portion of (that is, the sound device portion)

lspci -vv


Also, you may want to try running alsaconf and see what that does...
       I ran that first and that was all that was needed! It asked
       me a couple of questions with obvious answers; didn't seem
       to do much. (Strange. But Wow!)


You may find, like I did, that the alsa settings get lost on rebooting. A simple fix that worked for me is... 1. After running alsaconf and confirming that everything works, enter the command "alsactl store".
2. In /etc/rc.local, add the command "alsactl restore".

There are probably more elegant ways to fix the reboot problem, but this one seems to work fine.

jeff



Reply to: