[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Fresh 7.10 netinstall problems...

On Sat, Oct 27, 2007 at 05:30:49PM +0100, Digby Tarvin wrote:
> I hope there are some experts out there that can offer some suggestions
> regarding a problem I am having installing Debian Etch (40r1-386-netinst
> downloaded on 23/10/07) on a Dell Precision 410 MT...
> Everything goes fine through the initial install, up to the point
> where I have to reboot using the freshly installed kernel on the
> hard drive.
> I can log in after the reboot, and everything looks ok, but when I
> then proceed to try and complete the install by adding other packages
> like 'xorg', things start going wrong...
> Either the package transfer fails after a few minutes with messages like
>       E: Method http has died unexpectedly!
>       segmentation fault
> or dpkg falls over during the installation of the package, eg
>       /bin/sh: line 1: 2284 Segmentation fault /usr/bin/dpkg_preconfigure...
> I tried doing an 'apt-get update; apt-get upgrade' but the system did
> not survive long enough to get the updated kernel installed.
> It seems that the kernel used during the initial install was stable,
> but the kernel it installed on the hard disk is not.
> I tried adding 'nosmp' to the command line in case there were problems
> with that, but it made no difference.
> Any suggestions much appreciated.
> For anyone who has read this far - here are some more details about
> the target hardware:
>       Model: Dell Precision Workstation 410 MT
>       BIOS revision A08
>       CPU: 2xPIII 450MHz
>       Video card: 3DLabs Oxygen GVX1
>       Ram: 1024MB
>       Adaptec AIC-7890 BIOS DELL-V2.01.05
>               SCSI ID 0       COMPAQ  DDRS-34560W ULTRA2-SE
>               SCSI ID 1       SEAGATE ST173404LW  ULTRA2-SE
>       Adaptec AIC-7880 BIOS DELL-V2.01.05
>               SCSI ID 1   MATSHITA DVD-RAM LF-200
>       Primary IDE1    ZIP drive
> Regards,
> DigbyT
> --
> Digby R. S. Tarvin
> http://www.digbyt.com

This is a follow up to the post I made a few months ago as described
above, in case anyone else has a similar problem.

My initial workaround was to use the 486 Kernel, which was stable but
had reduced functionality, such as not being able to utilise the second
processor on this machine.

I have now had time to get back to investigating this, and after a
systematic test of all the differences between the 486 config and
the unstable 686 config, I have discovered that the critical item
was the setting for High Memory Support. In the 486 Kernel this
is set to 'off', and for the 686 kernel it is set to '4GB'.

When running the (stable) 486 kernel I get the dmesg message:
        Warning only 896MB will be used.
        Use a HIGHMEM enabled kernel.
        896MB LOWMEM available.

Having identified that this setting determines if my kernel will be
stable or not, I then tried booting the default (686) kernel with
the boot option 'mem=896M' (foregoing the top 128MB or ram)

Sure enough, the full pentium Debian kernel is now stable!

Still trying to find a way to determine if this indicates a fault
in this machine, or some subtle compatability issue with it.

If anyone has any idea what might be causing this particular fault I
would be most intetested to hear. I would have thought some bad ram
would have been detected by the BIOS or the install disk memory tests.
And I am told that the Windows system which it came with runs without
any problem. I wonder if there is anything about the way HIGHMEM is
used that would show up some subtle flaw in this machine?

Digby R. S. Tarvin                                          digbyt(at)digbyt.com

Reply to: