[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]


Backgroud - I had a well-established LAMP server that was giving some filesystem errors on boot, with the "hit control-D to continue or give root password to fix manually" message. It would go ahead and work normally if I hit Control-D.  However, I wanted to try to get rid of the error and need for human intervention in the event of the need for a remote reboot, so I tried to fix the errors with fsck.  Somehow I ended up with a badly trashed filesystem and inability to reboot.
After much knashing of teeth and consideration of my options, I installed a new etch system.  I installed several benign packages like apache.  I ran update and dist-upgrade to bring the system up to date.  When I ran the upgrade, it told me that it was trying to install an identical kernel image.  It explained some things about what it was doing about modules, and then said to be sure to reboot.  I did that, but then it gave me that now-familiar message about how the filesystem has errors, hit control-D to continue...
I booted with Knoppix, made sure my filesystem on /dev/hda1 was NOT mounted, and ran fsck -f.  It did the 5 passes without mention of errors.  I ran it a second time with same results.  However, when I boot from /dev/hda1, I still get the error about a filesystem with errors!
Trying to rebuild the server as it was is painful enough - Why would I be having these filesystem errors?  The HDD is relatively new.
Any other way to try to get rid of the boot error before I reinstall etch again?  I hate to do that because I don't understand how these errors originate, so I don't know why I shouldn't expect them to crop up again at some point later after another fresh install.
Why does the fsck during boot find errors when the fsck run via knoppix on the same filesystem return clean?
Thanks any help!  - John

Reply to: