[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Changing Ethernet Drivers [Solved]

Travis Crook <travis@visionsbeyond.com> writes:

> On Tue, 22 Jan 2008 14:53:47 -0700
> Travis Crook <travis@visionsbeyond.com> wrote:
>> On Tue, 22 Jan 2008 22:38:11 +0100
>> Jörg-Volker Peetz <jvpeetz@web.de> wrote:
>> > Travis Crook wrote:
>> > [...]
>> > >> First one in the list, after running modprobe forcedeth.  The
>> > >> question is: how do I tell the nic (which is a RealTek 8111
>> > >> Gigabit on-board adapter) to use the forcedeth driver instead of
>> > >> the r8169, which is automatically loaded on boot?
>> > > 
>> > >> Thanks!
>> > >>
>> > >>
>> > 
>> > Try to put the module name "r8169" into the file
>> > "/etc/modprobe.d/blacklist" before rebooting.
>> I tried the line "blacklist r8169" and rebooted - the module still
>> loaded.
> Well, once again, the solution was to boot into Windows, tell it to
> behave itself, then boot into linux and the whole world is happy.
> Here is the reference:
> "As of 27 May 2007, in kernel, you may experience the issues
> with the r8169 driver if you dual boot Windows on some systems. Windows
> by defaults disables the NIC at Windows shutdown time in order to
> disable Wake-On-Lan, and this NIC will remain disabled until the next
> time Windows turns it on. The r8169 driver in the kernel does not know
> how to turn the NIC on from this disabled state; therefore, the device
> will not respond, even if the driver loads and reports that the device
> is up. To work around this problem, simply enable the feature
> "Wake-on-lan after shutdown." You can set this options through Windows'
> device manager."

I had no end of trouble with that realtek ethernet.  Sometimes it
would just disappear from the list (lspci).  Every so often, even
windows wouldn't see it.  I scavanged an old 3com 905b pci card from a
retired machine in my basement.  Then I disabled the realtek from the
boot bios.  Problem solved.

Btw are there are any motherboards *not* using this POS realtek?
Every new board I have bothered to check had it.  I guess some might
have an intel ethernet chipset.  Unfortunately, newegg didn't give a
way to search motherboard on the basis of on-board ethernet make.

> and it's found here:
> http://gentoo-wiki.com/HARDWARE_RTL8168
> Thanks for all of the help and tips!  It's always a learning
> experience...
> -- 
> Travis Crook
> Visions Beyond
> www.VisionsBeyond.com
> 208-478-7836


Reply to: