[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Compatibility with ASUS P5E-VM HDMI

On Thu, Dec 27, 2007 at 07:55:06PM -0500, Douglas A. Tutty wrote:
> On Mon, Dec 24, 2007 at 12:17:46PM -0700, Rob Sims wrote:
> > On Thu, Dec 20, 2007 at 10:19:21PM -0500, Douglas A. Tutty wrote:
> > > On Thu, Dec 20, 2007 at 02:02:46PM -0500, Patrick Zaloum wrote:
> > > > I am shopping components for a (will-be) Debian server and am
> > > > currently considering the P5E-VM HDMI from Asus with the G35 chipset.
> > > > Detailed info can be found here
> > > > http://usa.asus.com/products.aspx?l1=3&l2=11&l3=584&l4=0&model=1912&modelmenu=1
> > > > Could anyone please help me determine if I might encouter
> > > > compatibility issues with linux (etch) especially at the level of the
> > > > SATA RAID controller, video and essentials. As it is a server, i don't
> > > > particularly care about the sound, hdmi, dual display, firewire.. but
> > > > the rest yes.
> > 
> > > No MB SATA "RAID" controller will be true raid.  Other than that, the
> > > only people that will know will be people who have tried.
> > 
> > Careful with those absolutes.
> > 
> > My ASUS P5W DH Deluxe has hardware RAID.  I haven't used it under Linux,
> > but as the RAID appears as a single SATA device, it should be
> > compatible.  However, the P5E-VM HDMI does appear to be software RAID.
> If you haven't tried it under Linux, then under what OS does it appear
> as a single SATA device?
As I mentioned in the post, Linux sees the controller, but there are no
disks for it to talk to.  There's a difference between "used" and
"detected."  Linux _detects_ something on the SATA port in question, at
3.0Gbps, but eventually finds no drive there, so I can't _use_ the
controller.  Truly disconnected SATA ports have a different, faster
indication to the kernel.

In addition, I did some research and found several statements saying
the same thing: the hardware RAID is attached to an SATA port.  The
board uses a Silicon Image 4723 Hardware RAID controller, found here:
The product brief is worth reading.

From the latest kernel sources (2.6.24-rc6+ - the patch was posted 2007-10-24,
/* On ASUS P5W DH Deluxe, the second port of PCI device 00:1f.2 is
 * hardwired to on-board SIMG 4726.  The chipset is ICH8 and doesn't
 * support PMP and the 4726 either directly exports the device
 * attached to the first downstream port or acts as a hardware storage
 * controller and emulate a single ATA device (can be RAID 0/1 or some
 * other configuration).
 * When there's no device attached to the first downstream port of the
 * 4726, "Config Disk" appears, which is a pseudo ATA device to
 * configure the 4726.  However, ATA emulation of the device is very
 * lame.  It doesn't send signature D2H Reg FIS after the initial
 * hardreset, pukes on SRST w/ PMP==0 and has bunch of other issues.
 * The following function works around the problem by always using
 * hardreset on the port and not depending on receiving signature FIS
 * afterward.  If signature FIS isn't received soon, ATA class is
 * assumed without follow-up softreset.

I'm guessing that the chip is really the 4723, as there are only two ports on
the board and the 4726 supports five, and the referenced bug reports say 4723
also.  Either way, it's SATA connected.

Attachment: signature.asc
Description: Digital signature

Reply to: