[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Window Borders Disappear

On Tue, 2007-11-20 at 20:59 -0800, Daniel Burrows wrote:
> On Tue, Nov 20, 2007 at 09:06:59PM -0600, Jack Schneider <puck@volunteerwireless.net> was heard to say:
> > On Tue, 2007-11-20 at 10:26 -0500, Michael Pobega wrote:
> > > On Tue, Nov 20, 2007 at 02:42:09PM +0000, Jack Schneider wrote:
> > > > I have lost my Desktop window borders. I am using Debian "lenny"
> > > > updated. Problem occurred after an abortedattempt to install Compiz..
> > > > I get the following error from theSystem>preferences>windows menu..  "
> > > > Cannot start the preferences application for your window
> > > > manager.Window manager "unknown" has not registered a configuration
> > > > tool..
> > > > 
> > > > Any help would be great...  J ack
> > > > 
> > > > 
> > > 
> > > Why don't you try aptitude reinstall metacity? That may work.
> > 
> > Thanks, for the reply...  I did the  # aptitude reinstall metacity thing
> > and regretably no change...
> > 
> > It really makes it painfull to have all windows in upper left corner
> > with no size or position control... What could be plan b???
>   If you can get access to the windows themselves: does running metacity
> from a terminal help?  If that complains that another window manager is
> running, try metacity --replace.  I think you have to save the Gnome
> session after that if it works, but I don't remember what the Gnome
> voodoo for saving a session is.
>   Daniel

Thanks, Daniel, That helps..  I now have window's with borders on
current screen , after running:  sudo metacity --replace.  I get an
error though!!  

[Window manager warning: Failed to load theme "Clearlooks": Failed to
find a valid file for theme Clearlooks]  
and I am not sure this condition will be there at next login....

Re: Andrei's question.. 
" How did you try to install compiz? Please detail your steps, maybe we 
can find a way to revert what has been done."

Since it's been a couple of day's, this is best that I can recall.  

I run a NVIDIA Geforce 8600GT video card.  So There were some howto's on
the (I think) Debian-Compiz wiki. calling for some changes to xorg.conf
under "etch".  I run "lenny" but the same video driver as I did under
"etch", NVIDIA 100.14.19 so  I added the suggested changes...via $ sudo
vim /etc/X11/xorg.conf.
I recall a addtion entry to the "device' section and a new "extensions"
then I used " # aptitude install compiz " to load Compiz.  It installed
with out error... I then logged out and in. and that's where the problem
happened... I PANICed !   I was able to use a xterm OK so I replaced the
xorg.conf from xorg.conf.bak and # aptitude remove compiz....OK.  That
didnt help.

Then I asked for help....  This is the best I can remember...Memory is
slipping as I get older...really old...8-(

Thanks, to both of you...

Reply to: