[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Cannot run iceweasel on remote host

Liam O'Toole wrote:
On Wed, 03 Oct 2007 18:08:29 +0530
Raj Kiran Grandhi <grajkiran@gmail.com> wrote:


I am facing a weird problem when trying to run iceweasel on a remote host through an ssh session. I have logged into the remote host using "ssh -Y <remote>" and at the prompt of the remote host, I ran
iceweasel. However it appears that a local instance of iceweasel is
started. There is no iceweasel/firefox process at all on the remote
host. The only way I could get iceweasel to run on the remote host is
by closing all instances of iceweasel already running on the

Is something wrong?

No, it's a feature :-)

If not, how do I run separate instances of
iceweasel concurrently?

Invoke iceweasel on the remote host by issuing the command 'iceweasel

That's it! Thank you. But I am curious as to how the iceweasel script running on the remote host is able to spawn/control the local process without authentication. I have not added the remote hosts key in my authorised_hosts file.

Raj Kiran

Reply to: