[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: libc6 dependencies

On Mon, Oct 01, 2007 at 11:00:10 -0700, Curtis Vaughan wrote:
> I was updating an etch server when I ran into the following error:
> The following packages have unmet dependencies:
>   libc6-dev: Depends: libc6 (= 2.3.6.ds1-13etch2) but 2.3.6.ds1-13 is 
> installed
> I ran apt-get -f install which yielded:
> Preparing to replace libc6 2.3.6.ds1-13 (using 
> .../libc6_2.3.6.ds1-13etch2_i386.deb) ...
> /var/lib/dpkg/tmp.ci/preinst: line 130: ls: command not found
> /var/lib/dpkg/tmp.ci/preinst: line 130: ls: command not found
> Unpacking replacement libc6 ...
> dpkg: error processing 
> /var/cache/apt/archives/libc6_2.3.6.ds1-13etch2_i386.deb (--unpack):
> unable to create `./usr/sbin/zic': Permission denied
> dpkg-deb: subprocess paste killed by signal (Broken pipe)
> Errors were encountered while processing:
> /var/cache/apt/archives/libc6_2.3.6.ds1-13etch2_i386.deb
> E: Sub-process /usr/bin/dpkg returned an error code (1)
> I am root, so I don't understand the permission denied. Why certain 
> commands aren't found is even more perplexing.
> Any ideas?

I would start with the first problem: "ls: command not found". (The
permission issue might be a consequence of whatever goes wrong before.)

As root, what output do you get from these commands:

echo $PATH

which ls

file `which ls`

stat `which ls`

lsattr `which ls`

Regards,            | http://users.icfo.es/Florian.Kulzer
          Florian   |

Reply to: