[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: X fails to start - Intel i810 (845) - etch + testing

On Sun, Sep 09, 2007 at 10:19:10PM -0500, Gordon Pedersen wrote:
> Hi,
> New etch installation on box with builtin video Intel 845.
> This is a fresh etch install, i386, 2004 hardware.  See DETAILED
> NOTES below for hardware notes, xorg.conf and Xorg.0.log.
> Does anyone have X working on one of these builtin Intel 845 chipsets?

yep. In fact I think I have a 845G Brookdale running in sid right now
and it worked fine in etch, but my monitor wasn't supported, hence the
upgrade to sid.

> I have tried the following changes to xorg.conf:
>         -       no DRI
>         -       no DRI and no glx
>         -       no "Modes" lines
>         -       use "vesa" instead of "i810"

i810 is being replaced by intel, so fix up your xorg.conf to reflect
intel instead, but that's not your problem here.

> Finally, I installed testing versions of xserver-xorg and
> xserver-xorg-video-i810.  Still can't get X to start, although now I
> get that special "click" sound when it tries to start.

the log you included doesn't look like the log of a failed X
session. What exactly happens, other than the magical "click" when the
monitor changes modes?  Do you end up back at a VT? do you get a
garbled or black screen? details!

one note from the logs, it is selecting an initial resolution of
1920x1200. Does your monitor really support that? it looks like a
hitachi from 1996, and I'd be surprised. I'm guessing that you're
getting a bad mode setting that's not compatible with your monitor. 

try ctrl-alt-keypad'-' or keypad'+' and see if you can toggle your way
into a different mode.

> Any ideas?  What can I try?

the new intel drivers do a fairly decent job of guessing all the
details about your setup. 

I would clean up the xorg.conf by getting rid of all the SubSection
"Display" lines and the VideoRam lines. This would prevent xorg from
trying to second guess what the drivers are telling it. Also, have you
done a good dpkg-reconfigure xserver-xorg?


Attachment: signature.asc
Description: Digital signature

Reply to: