[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Issues with ethernet in testing/lenny

Hello, I've recently purchased a Dell Inspiron 530 and wanted to get
Debian onto it. I've installed Lenny mostly without any issues, but it
did not autodetect my ethernet card. It is a 82562V-2 integrated card,
at least according to the Windows Vista devise manager.

Anyway, I do have a very basic system up and running. No internet
support or anything, so I can really only do stuff from the Windows
side of my system right now. I'm not sure how I can get logs of what I
do to my email from Debian so I'm sorry about the lack of the logs.
I'll do my best to describe the error messages however.

As I stated earlier, the installer did not detect the network card. I
tried loading the "e1000" module inside the installation program which
according to intel should be the module I need:

The installer wouldn't acccept it, it would just loop back to the
"select module" screen. I tried to "modprobe e1000" manually during
the installation, but that didn't work either. No error messages come

After that, the rest of the system installed without any hassle, but
obviously I cannot connect to the internet right now without any
network card, so I don't have anything installed aside from whatever
is on the base netinstall on Lenny.

I've tried to "modprobe e1000" after the installation, and there seems
to be no errors that happen. I use dmesg and aside from the loading
message from e1000, no other messages pop up. I've also added "iface
eth0 inet dhcp" into my /etc/network/interfaces file, and tried to do
"ifup eth0", but that fails with the message: 'Device "eth0" does not

Thank you for reading this message. I'd really like to get Debian up
and running as soon as possible so please help. As an aside, all error
messages and other logs are from memory + google. So they may not be
100% correct but they're the best I got right now.

Reply to: