[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[solved] The mystery of the misbehaving 120 Spacecam

Jonathan Kaye wrote:

> Hi Debianers,
> This is a real puzzler and a challenge to all. I'm running Debian Lenny
> with a 2.6.18-4-686 kernel. My DM is KDE somewhere between 3.5.5 and 3.5.7
> as the KDE updates trickle down to testing. I rescued a Trust 120 Spacecam
> USB webcam that my friend was throwing out because he couldn't get it to
> work on windows ;-). I rescued it from the dustbin and found that it
> worked well (it's a cheap camera so "well" means it produced a
> recognisable image) will the spca5xx driver. The driver stopped working
> when I upgraded my kernel and I couldn't find the source code to rebuild
> it for the new kernel. After a few months I noticed that there was a
> Debian package spca5xx-source and I could build the module for my kernel
> and it worked!!!!!!!!
> For some reason I don't understand the webcam stopped functioning a few
> days ago. I haven't changed kernels but there have been some minor
> upgrades of xorg recently. The symptoms are that there is no image for
> xawtv, ekiga, kopete, that its little light stays on all the time whereas
> before it would only light up when it was being used by some program and
> then go off when the program terminated and finally, the whole system
> would lock up if I unplugged the videocam while the system was running.
> Even alt-sysrq + b wouldn't work and I had to do a hard reset. Be that as
> it may, I rebuilt the module (about 5 times) and still no luck. The little
> light shines and shines. No response from any programs except one. This is
> really weird: amsn is quite happy with it although the light doesn't go
> out when I shut down amsn. It still doesn't work with xawtv,ekiga or
> kopete. Now some information:
> Yes, I am a member of the video group.
In case anyone is interested, my problem came about because my webcam is now
recognised as a v4l2 camera as opposed to a v4l camera. My guess is that
this change has come into effect recently and I needed to reconfigure the
programs that use the webcam.

Registerd Linux user #445917 at http://counter.li.org/

Reply to: