[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

BAD Error Installing new Apache2 & PHP?

I'm running Debian kernel version 2.4.27-2-386. I needed to upgrade Apache (from 2.0.54) & PHP (from 4.3.10-16) on our system. After doing “apt-get update” I executed the command:


apt-get -y install apache2-mpm-prefork apache2-doc lynx php4 libapache2-mod-php4


Using -y, the only prompt I received was near the bottom of the output (see excerpt below), to which I answered 'No'

when it asked whether I wanted to remove the kernel =:0


I haven't yet killed the apache2 processes, but do you know if the msgs below indicate a real problem? Why would there be a need to remove the kernel? Should Apache2/PHP run ok anyway? I haven’t yet killed the apache2 processes so they still run ok for now. Is it likely I have a problem?


Thanks again,




Removing kernel-image-2.4.27-2-386 ...


You are running a kernel (version 2.4.27-2-386) and

attempting to remove the same version. This is a potentially

disastrous action. Not only will /boot/vmlinuz-2.4.27-2-386

be removed, making it impossible to boot it,

(you will have to take action to change your boot loader

to boot a new kernel), it will also remove all modules

under the directory /lib/modules/2.4.27-2-386.

Just having a copy of the kernel image is not enough, you

will have to replace the modules too.


I repeat, this is very dangerous. If at all in doubt,

answer no. If you know exactly what you are doing, and

are prepared to hose your system, then answer Yes.


Remove the running kernel image (not recommended) [No]? No


                dpkg: error processing kernel-image-2.4.27-2-386 (--remove):

                subprocess pre-removal script returned error exit status 1

                dpkg: initrd-tools: dependency problems, but removing anyway as you request:

                kernel-image-2.4.27-2-386 depends on initrd-tools (>= 0.1.48).

                Removing initrd-tools ...

                Errors were encountered while processing:


                E: Sub-process /usr/bin/dpkg returned an error code (1)


Reply to: