[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Strange dhcp difficulty with 2.6.20+ kernels

Not too long ago I was going to upgrade my kernel, I am currently
running, and downloaded the latest 2.6.20 tarball.  I went
through the usual steps.  I configured it carefully and then
compiled it via make-kpkg.  Lastly I installed it with dpkg.  When I
rebooted everything seemed okay, but then I found that I had no
connection on eth0.  This is a dhl modem connected via a linksys
router, and is set up with dhcp3-client which has generally worked

Running ifconfig showed eth0 to be configured, and it looked just as
it usually does, at least as far as I could tell.  But, I could ping
nothing outside of my own box.  I also could not connect to my router
or the modem itself.  If I try pinging anything I can see the lights
on the front of the router flashing, as they should, but nothing is
coming through.

At this point I have tried to compile a 2.6.20-1, 2.6.20-11 and
2.6.21-1, and all have ended up the same.  Actually, the 2.6.21 also
gave me a kernel panic, but I am gathering this is a bug from the
sis900 module that my nic uses.  The mystery for me is that I just
don't know where to start looking for the trouble.  Dmesg looks just
as it always does when setting up eth0, and if I run ifdown eth0 and
ifup eth0 the response looks very normal too.  My resolv.conf is
also the same as always.  I just have no connection and no indication
as to why.

Where might I start looking for the trouble?  Is there a way to get
some more data with a hint of just what is not working as it should?
As of right now I just don't know where to look.

Many thanks,


Reply to: