[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

mdadm - raid1 - sata - udev - kernel-2.6.16-2-686 - Problems

debian sarge -  mdadm 1.8.0-4sarge1


my problem is that on reboot the only md device that comes up is md1 which is the / device that gets compiled into the initrd.img.

in the boot sequence when it comes to mounting the others from /etc/fstab it can't find the md device and drops me to maintentance mode.

If I remove the devices from fstab and just let the initrd.img do it's stuff then it boots fine. from that point If I run /etc/init.d/mdadm-raid start it doesn't work, but if I run /sbin/mdrun then all the md devices appear as they should.

I am a little confused as to what's happening, If I put /sbin/mdrun in the init.d and run it at level 20 the md devices will load, but they still will not mount correctly out of /etc/fstab.

After it has booted i can mount manually no problems.

I have added these to /etc/udev/links.conf

M md0 b 9 0
M md1 b 9 1
M md2 b 9 2
M md3 b 9 3
M md4 b 9 4

I am wondering if this is something to do with udev.

Any Clues anyone ?


Reply to: