[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Cdrecord with a 2.4 kernel

I thought this problem only occured with a 2.4 kernel, but it is also happening with a 2.6 kernel.



2007/1/23, Sonixxfx < sonixxfx@gmail.com>:
I am trying to burn multisession cd's with cdrecord but I have a problem. After I have written a multisession disc, and mount it, the burned files are not shown at /media/cdrom. The files are written to the disc though, because I can access/see them when I have rebooted my system and mount the cd.
I am running Debian Sarge with a 2.4 kernel. I don't have this problem with a 2.6 kernel. I have tried cdrecord and mkisofs from Debian stable, I have tried wodim from backports.org , and I have tried the latest Cdrecord which I have compiled and installed myself. I have also tried my own compiled 2.4 kernel.
I believe I have done everything that is needed to run Cdrecord together with a 2.4 kernel:
1)  I have appended "hdc=ide-scsi" to the kernel line in Grub. 
2)  I have loaded the modules sr_mod, sd_mod, ide-scsi and sg.
3)  I did not load the ide-cd module.
4)  I also adapted /etc/fstab and substituted the "/dev/hdc" part with "/dev/scd0"
Also cdrecord -scanbus shows my (Sony but I have also tried this with a HP) writer, and burning and everything else seems to go fine.
So does someone know what I can do about this?
Thanks for your help.

Reply to: