[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: gtk-gnutella problems

Hugo Vanwoerkom wrote:
Hugo Vanwoerkom wrote:
Jan Willem Stumpel wrote:
Gerard Robin wrote:

I am afraid I can't help you but I use gtk-gnutella
0.96.1svn12109-1 too (with unstable) and it works fine for me.

Hmm.. maybe it has something to do with the fact that I have a
firewall on a separate machine?

Anyway I filed a bug about this, and quickly received an answer
(by Christian Biere) to the effect that gtk-gnutella is hardly
maintained in Debian (or not at all; it seems to be completely
missing from Etch). He pointed me to detailed (but simple)
instructions for making a .deb file from (recent) source. This
worked very well, because the source file is already prepared for
Debian. See


With this version, when the "listen port" in "preferences" matches
the forwarded port in the firewall, gtk-gnutella reports that I am
not firewalled, as it should.

Anybody have a firehol config entry for this?
I get an:
Cannot accept an empty 'dport'

I'm getting tired of Firehol and its mystery statements.

I tried:

       server gtk-gnutella accept

I figured it out: gtk-gnutella cannot have a '-'.

So if another poor Firehol soul is looking for gtk-gnutella parms, this works:

server_gtkgnutella_ports="tcp/43432 udp/43432"
        server gtkgnutella accept

Note the absence of the '-' in 'gtkgnutella'. You put that back in and he complains of a missing dport.

And now gtk-gnutella shows a happy face where previously the firewalls were burning.


Reply to: