[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Kernel 2.6.17 e 2.6.18 K7 network problem [SOLVED]

--- Antonio Laterza <anlater2001@yahoo.it> ha scritto:

> Hi all, I want to ask if somebody experienced the same
> problem I have with etch installation and in general with
> kernel 2.6.17 and 2.6.18 on AMD K7. The computer where I
> tried has 2 network cards, I connect only 1 card and it
> receives the IP address.
> I experienced the problem installing etch using a
> businesscard, using knoppix 5.0.1 (use kernel 2.6.17) and
> upgrading from sarge (kernel 2.6.8) to etch (kernel
> 2.6.18). 
> In the last case, with the same installation if I chose
> kernel 2.6.8 I have no network problem (but X does not
> work
> :( ). If I choose the kernel 2.6.18 X is OK but I am not
> able to reache many sites. I can navigate very few sites
> example: www.google.com and www.mozilla.org. Using
> ethereal
> seems that the HTTP request go out (i.e. GET / ....) but
> the ACK packet does not ask the next packet number ....
> in
> other words seems that the GET request never reched the
> final site.
> I tryied to reduce the MTU but was unsuccesful. 
> Last details: the network card is the Realtek ....
> Regards
> anlater 
Hi all, just to report the solution was suggested by
Hendrik Sattler on debian-devel list.
> TCP windows scaling comes to mind:
> http://lwn.net/Articles/92727/
> HS
Wow!!! Best regards Hendrik!!!
Most probabily the provider's router is buggy but it solved
the problem.
The solution was that reported by article pointed by you:

In the mean time, anybody running a current kernel who is
having trouble connecting to a needed site can work around
the problem with a command like:

    echo 0 > /proc/sys/net/ipv4/tcp_default_win_scale 

or by adding a line like:

    net.ipv4.tcp_default_win_scale = 0

to /etc/sysctl.conf.


Do You Yahoo!?
Poco spazio e tanto spam? Yahoo! Mail ti protegge dallo spam e ti da tanto spazio gratuito per i tuoi file e i messaggi 

Reply to: