[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

No SNMP output on Etch

I'm trying to get some snmp info from my Debian Etch (testing) box. But
i don't seem to get any output.
Etch:/# snmpget -v 1 -c public localhost system.sysUpTime.0
Error in packet
Reason: (noSuchName) There is no such variable name in this MIB.
Failed object: DISMAN-EVENT-MIB::sysUpTimeInstance

So i tried a simple snmpwalk, but that also gives me nothing:
Etch:/# snmpwalk -v 1 -c public localhost
End of MIB

I've verified that snmpd is listening:
Etch:/# netstat -natup | grep 161
udp        0      0*        6347/snmpd
So that seems ok.

I've created this bare settings file in /etc/snmp/snmpd.conf
# /etc/snmp/snmpd.conf
#         sec.name  source     community
trapsink  readonly  localhost  public
#                sec.model  sec.name
group MyROGroup  v1         readonly
#           incl/excl subtree                          mask
view all    included  .1                               80
#                context sec.model sec.level match  read   write  notif
access MyROGroup ""      any       noauth    exact  all    none   none
# end of file
And stopped en started snmpd (restart only stops snmpd, this seems like
a bug). But still no results on snmpwalk:
Etch:/# snmpwalk -v 1 -c public localhost
End of MIB

Any ideas where things go wrong? Or anyone that has got snmpwalk
working on Etch?

Reply to: