[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: /dev/dsp missing (SOLVED)

On Sat, Dec 30, 2006 at 03:53:14PM +0100, Benjam? Villoslada wrote:
> I've seen this message durning one reboot (in order to test oss modules 
> load): "/etc/modprobe.conf exists but does not include /etc/modprobe.d/!"
> I see that my /etc/modprobe.conf is empty (no idea about the reason)  I've 
> added include /etc/modprobe.d and now the system loads oss modules on boot:
> $ cat /etc/modprobe.conf
> include /etc/modprobe.d

I did this on my sarge system (which also didn't have a /dev/dsp) and 
one appeared.  I could cat from it, and cat /dev/urandom to it and get 
noise.  There are probably better things to cat to it.

Unfortunately, after I did this, none of my audio programs worked.  
Couldn't get sound out of kaffeine, xmms, konqueror....

Is this a matter of /dev/dsp disabling alsa or something?

When I took the line out of /etc/modprobe.conf, making it empty again, 
and rebooted (just in case), /dev/dsp vanished, and sould still didn't 
come back.  I had a mute system.  It took powering it down to restore 
normal sound, without /dev/dsp.  This is probably a bug somewhere, that 
the sound card isn't being initialised properly.

Can anyone tell me how to get audio input without disbling the rest of 
the sound system?  That's what I thought I needed /dev/dsp for. I need 
to rip cassette tapes of church services to post on the church web site.

-- hendrik

Reply to: