[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Sarge: name resolution weirdness

So yesterday my Sarge server couldn't resolve any host names.  Restarting
resolvconf did nothing.  Adding new servers to /etc/resolv.conf did nothing,
even though dig@thoseservers worked fine.

I finally apt-get removed resolvconf and then rebooted (virtual server via
Rimuhosting).  That worked.

Except since then I got no mail.  Almost all of my mail is forwarded via my
server (which answers to both finknetwork.com and fink.to) to my account on

Checking the mail logs on my box showed that panix.com was an "unknown
service".  Uh, what?  I could, for instance, ping Panix and it would work. I
could "dig -t mx panix.com" and be told that I needed mx.panix.com.  But
Postfix, only, couldn't resolve hostnames.

A bit of investigation showed that /etc/resolv.conf was a broken symbolic
link to a nonexistent /etc/resolvconf/run/resolv.conf.  Why?  I removed the
resolvconf package and rebooted--why would a reassignment like that happen? 
And in any case, how were other programs resolving if resolv.conf was

Recreating resolv.conf STILL didn't work, even after I restarted Postfix. I
had to reboot again.

I HATE rebooting Linux boxes (even virtual ones).  Hate it.

Does anyone have an idea what the heck happened?
Carl Fink                                   nitpicking@nitpicking.com 

Read my blog at nitpickingblog.blogspot.com.  Reviews!  Observations!
Stupid mistakes you can correct!

Reply to: