[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: upgrade of etch from beta2 net install to current level

Re: upgrade of etch from beta2 net install to current level
Andrew Sackville-West <andrew@farwestbilliards.com>
Thu, 21 Dec 2006 09:42:39 -0800


On Thu, Dec 21, 2006 at 03:50:55AM -0600, Gayle Lee Fairless wrote:
> I have a dual-booting box with an ASUS P4P800e Deluxe motherboard >(socket 478) with a Radeon ATI 9550 graphics card. Etch using grub >was installed this past spring 2006 with a 2.6.12 kernel from the >beta2 network installation CDROM.
> Since I now have ADSL (the motherboard has built-in IEEE 1394 WAN), >I tried to upgrade etch with aptitude update and aptitude upgrade. It >attempted to remove my only running kernel. I declined that option. >It has hosed my display after reboot. I scripted the upgrade and >believe that I can retrieve the text file if that is needed.
>I was also foolhardy enough to attempt linux-image-2.6.18-3-686, but >it also wanted to remove 2.6.12 which is my only kernel. Once I get >Windows XP Professional configured correctly, I suppose I could >download a current iso image and reinstall or just use Kubuntu. >Mainly I want to know if I can use aptitude to finish the upgrade >properly and then I would like to know the way to upgrade from 2.6.12 >to 2.6.18 so that I can use a smp kernel with the Pentium 4 Prescott.
> Thanks for any help on the Debian recommended way to proceed.

I tried Sackville's suggestion to mark the 2.6.12, but aptitude had already purged dependent packages and was dead set on removing it. Fortunately or unfortunately, it seems that aptitude (0.4.1, I think) was intent on downloading the whole mirror or so it seemed. It downloaded and installed about ten of the *86 kernels of version 2.6.18. I have to boot into a recovery kernel and enter root password to get into maintenance mode.

can you issue `init 2` from the maintenance mode? what does it do?

The normal login won't show a password
prompt to let me get in.

what does it do then?

Also, the graphics system is not displaying.

one thing at a time...

I can mount my Windows XP partition which also won't boot so I can recover data. Grub seems to work fine. I'm just not proficient in it yet.

we can fix that. what partition is xp on? mine is on hdb1 or in grub
speak (hd1,0) so I have in my menu.lst

title MS Windows XP
root (hd1,0)
chainloader +1

and that worked fine for me until i killed windows.
However, I did get aptitude to upgrade to its latest version 0.4.4 that Joey Hess mentioned in a previous post. I'm getting there but can still use helpful comments.

sometimes for big upgrades you have to run it multiple times to get it
through all the way. what exactly have you run so far? and did it run
to completion?

My system has exhibited weird behavior. It now boots into Windows. I can get to the Linux partition with the rescue mode of the original network installation CDROM for etch with kernel 2.6.15.

Also, the boot priority suddenly changed to the harddrive. I had to change the boot priority in the BIOS to boot from CDROM.

I had also looked at the system with the installation CDROM's for Windows XP Professional. I'm not aware that I told it to change anything; however, it may have 'volunteered quietly.' Oh well, I'm going to back up my Windows data and then be ready to repair the Debian GNU/Linux etch installation still on /dev/hda6.

I'm swearing off eggnog (except at Mother's) and grub-install to avoid ruining the MBR.

What can we do with the rescue mode of the installation beta2 CDROM?

Reply to: