[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: upgrade of etch from beta2 net install to current level

On Thu, Dec 21, 2006 at 03:50:55AM -0600, Gayle Lee Fairless wrote:
> I have a dual-booting box with an ASUS P4P800e Deluxe motherboard >(socket 478) with a Radeon ATI 9550 graphics card. Etch using grub >was installed this past spring 2006 with a 2.6.12 kernel from the >beta2 network installation CDROM.
> Since I now have ADSL (the motherboard has built-in IEEE 1394 WAN), >I tried to upgrade etch with aptitude update and aptitude upgrade. It >attempted to remove my only running kernel. I declined that option. >It has hosed my display after reboot. I scripted the upgrade and >believe that I can retrieve the text file if that is needed.
>I was also foolhardy enough to attempt linux-image-2.6.18-3-686, but >it also wanted to remove 2.6.12 which is my only kernel. Once I get >Windows XP Professional configured correctly, I suppose I could >download a current iso image and reinstall or just use Kubuntu. >Mainly I want to know if I can use aptitude to finish the upgrade >properly and then I would like to know the way to upgrade from 2.6.12 >to 2.6.18 so that I can use a smp kernel with the Pentium 4 Prescott.
> Thanks for any help on the Debian recommended way to proceed.

I tried Sackville's suggestion to mark the 2.6.12, but aptitude had already purged dependent packages and was dead set on removing it. Fortunately or unfortunately, it seems that aptitude (0.4.1, I think) was intent on downloading the whole mirror or so it seemed. It downloaded and installed about ten of the *86 kernels of version 2.6.18. I have to boot into a recovery kernel and enter root password to get into maintenance mode.

can you issue `init 2` from the maintenance mode? what does it do?

      I don't know.  I shall try it this weekend and report back.

The normal login won't show a password
prompt to let me get in.

what does it do then?

It skips the password prompt and goes immediately to the login prompt. Every 5th time it tells me that I've tried 5 times.

Also, the graphics system is not displaying.

one thing at a time...

The repeated upgrades might fix that, too. The basic system is running fine in spite of having the running 2.6.12 'shot out' from under me!

As I said, I have been choosing the 2.6.18 ... 686 recovery mode kernel since that would appear to match my system. I don't know that I need the vserver and xen flavors. Do I? (It might be interesting to keep them for later, perhaps.)

I can mount my Windows XP partition which also won't boot so I can recover data. Grub seems to work fine. I'm just not proficient in it yet.

we can fix that. what partition is xp on? mine is on hdb1 or in grub
speak (hd1,0) so I have in my menu.lst

title MS Windows XP
root (hd1,0)
chainloader +1

and that worked fine for me until i killed windows.

/dev/hda1 is Windows XP Professional.   /dev/hda6 is the Debian partition.

I was able to use cfdisk to reveal the partition table. I am going to set /dev/hda1 to ntfs (because that is what it is supposed to be). I suspect that it still won't boot. Before I do that, I shall save off the data files to my Jaz drive and to my ordinary account in the Linux partition. Then I would have the data files in two locations. Everything else can be re-installed, if necessary. (That'll take 2 or 3 pots of coffee!)

I think I did a grub-install into hd0,1 and trashed the Windows partition. Fortunately, the partition is mountable from Linux and so is my Jaz drive. I suspect that I'll have to retrieve the data files, do a Quick Format on /dev/hda1 with the Windows installation CDROM's and re-install.

However, I did get aptitude to upgrade to its latest version 0.4.4 that Joey Hess mentioned in a previous post. I'm getting there but can still use helpful comments.

sometimes for big upgrades you have to run it multiple times to get it
through all the way. what exactly have you run so far? and did it run
to completion?

I suspected that I would have to update and upgrade several times. However, I think I'm in a loop, or I'm just seeing various packages use the same common packages such as python2.3. Before I let aptitude remove the 2.6.12 kernel, it would only show a red highlight with BB for the Broken Broken flags or purple highlight with Bd for the Broken and delete flags. It had already killed the initrd-tools package on which the 2.6.12 kernel package depended.


I shall try the init 2 command from the prompt in maintenance mode this weekend. Should I do it from the root prompt (#) or the user prompt ($)?

      I did try startx from the root prompt.  No joy.

Thank you for your comments. I appreciate the insight because I sometimes get lost in the details!

Reply to: