[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problem installing packages with apt-get, aptitude and dselect

Hi list. I'm running into a little bit of a problem with package management on my system and I was hoping someone out there might help:

My problem occurs with apt-get, aptitude, dselect, synaptic or any other front-end to apt.

I can manually download packages and successfully install/upgrade them using dpkg. In fact, I gave the 'smartpm' package manager a try and found it to work successfully because it uses dpkg directly and not apt.

My problem is as follows: When I run 'aptitude upgrade' or 'apt-get upgrade' I get a segmentation fault when it tries to update the list of packages (I guess that's what the message says, but it is overwritten with "Segmentation fault"):

[10:22][root@sweety:~]$ aptitude upgrade
Segmentation faultsts... 0%

Segmentation faultsts... 0%
[10:22][root@sweety:~]$ apt-get upgrade
Segmentation faultsts... 0%

If I try to update with 'apt-get update' or 'aptitude update' (the output is the same for both), the update completes but, again, when they get to the "update the lists" part (I don't know exactly what the message is exactly because it's "overwritten" with "Segmentation fault"), there is a segfault:

[10:24][root@sweety:~]$ aptitude update
Get:1 http://http.us.debian.org testing Release.gpg [378B]
Get:2 http://http.us.debian.org unstable Release.gpg [378B]
Get:3 http://debian-multimedia.dfoell.org unstable Release.gpg [189B]
Hit http://http.us.debian.org testing Release
Get:4 http://security.debian.org testing/updates Release.gpg [189B]
Hit http://debian-multimedia.dfoell.org unstable Release
Hit http://http.us.debian.org unstable Release
Hit http://security.debian.org testing/updates Release
Get:5 http://snapshot.debian.net unstable Release.gpg [189B]
Hit http://snapshot.debian.net unstable Release
Hit http://http.us.debian.org testing/main Packages/DiffIndex
Hit http://http.us.debian.org testing/non-free Packages/DiffIndex
Hit http://http.us.debian.org testing/contrib Packages/DiffIndex
Hit http://http.us.debian.org testing/main Sources/DiffIndex
Hit http://http.us.debian.org testing/non-free Sources/DiffIndex
Hit http://http.us.debian.org testing/contrib Sources/DiffIndex
Ign http://debian-multimedia.dfoell.org unstable/main Packages/DiffIndex
Hit http://http.us.debian.org unstable/main Packages/DiffIndex
Ign http://debian-multimedia.dfoell.org unstable/main Sources/DiffIndex
Hit http://http.us.debian.org unstable/non-free Packages/DiffIndex
Hit http://http.us.debian.org unstable/contrib Packages/DiffIndex
Hit http://http.us.debian.org unstable/main Sources/DiffIndex
Hit http://http.us.debian.org unstable/non-free Sources/DiffIndex
Hit http://http.us.debian.org unstable/contrib Sources/DiffIndex
Ign http://security.debian.org testing/updates/main Packages/DiffIndex
Hit http://debian-multimedia.dfoell.org unstable/main Packages
Ign http://security.debian.org testing/updates/contrib Packages/DiffIndex
Ign http://security.debian.org testing/updates/non-free Packages/DiffIndex
Ign http://security.debian.org testing/updates/main Sources/DiffIndex
Ign http://security.debian.org testing/updates/contrib Sources/DiffIndex
Ign http://security.debian.org testing/updates/non-free Sources/DiffIndex
Hit http://security.debian.org testing/updates/main Packages
Hit http://security.debian.org testing/updates/contrib Packages
Hit http://debian-multimedia.dfoell.org unstable/main Sources
Hit http://security.debian.org testing/updates/non-free Packages
Hit http://security.debian.org testing/updates/main Sources
Hit http://security.debian.org testing/updates/contrib Sources
Hit http://snapshot.debian.net unstable/main Packages/DiffIndex
Hit http://security.debian.org testing/updates/non-free Sources
Hit http://snapshot.debian.net unstable/contrib Packages/DiffIndex
Hit http://snapshot.debian.net unstable/non-free Packages/DiffIndex
Fetched 5B in 15s (0B/s)
Segmentation faultsts... 0%

The only sort of clue that provides something meaningful, that I can't figure out is dselect. When I update in dselect, I get the same output as above (up to the "Fetched" line) with the following error:

/usr/lib/dpkg/methods/apt/update: line 42: 8949 Segmentation fault $APTGET $OPTS "$APT_OPT0" "$APT_OPT1" update

update available list script returned error exit status 1.
Press <enter> to continue.

I really don't understand the error message much and seem to not know what to do. I ran 'dpkg --audit' to make sure there are no "half-installed" packages that might be ruining my system and there are none (I get no output). Beyond that, I really don't think I've done anything to produce this on my system!

Unfortunately, I can't install any new packages with apt-get or aptitude and cannot upgrade as I normally do with either of them. Anyone know what might be going on or how I might fix this? I'd really appreciate some help. Thanks so much in advanced.

Jose Alburquerque

Reply to: