[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Trouble building OpenOffice.org from source

On Tue, 2006-12-05 at 14:09 +0100, Stefan Bellon wrote:
> Hi!
> I'm trying to build OpenOffice.org 2.0.4 from the official sources. I
> downloaded the source tarball
> http://openoffice.bouncer.osuosl.org/?product=OpenOffice.org&os=src〈=en&version=2.0.4
> (300 MB) and followed the instructions at
> http://tools.openoffice.org/dev_docs/build_linux.html#BuildRequirements
> The requirements are all fulfilled and the configuration was done with:
> $ ./configure --disable-mozilla --with-mingwin=i586-mingw32msvc-g++
> But when I build, I run into trouble, regardless of whether I use GCC
> 3.3, 3.4 or GCC 4.0, 4.1 for building.
> With the GCC 3.x series I run into those kinds of trouble:
> g++-3.3 -Wl,-rpath,'$ORIGIN' --fexceptions -shared
> -o ../lib/libstlport_gcc.so.4.5  ../lib/obj/GCC/ReleaseD/dll_main.o ../lib/obj/GCC/ReleaseD/fstream.o ../lib/obj/GCC/ReleaseD/strstream.o ../lib/obj/GCC/ReleaseD/sstream.o ../lib/obj/GCC/ReleaseD/ios.o ../lib/obj/GCC/ReleaseD/streambuf.o ../lib/obj/GCC/ReleaseD/stdio_streambuf.o ../lib/obj/GCC/ReleaseD/istream.o ../lib/obj/GCC/ReleaseD/ostream.o ../lib/obj/GCC/ReleaseD/iostream.o ../lib/obj/GCC/ReleaseD/codecvt.o ../lib/obj/GCC/ReleaseD/collate.o ../lib/obj/GCC/ReleaseD/ctype.o ../lib/obj/GCC/ReleaseD/monetary.o ../lib/obj/GCC/ReleaseD/num_get.o ../lib/obj/GCC/ReleaseD/num_put.o ../lib/obj/GCC/ReleaseD/num_get_float.o ../lib/obj/GCC/ReleaseD/num_put_float.o
> ../lib/obj/GCC/ReleaseD/numpunct.o ../lib/obj/GCC/ReleaseD/time_facets.o ../lib/obj/GCC/ReleaseD/messages.o ../lib/obj/GCC/ReleaseD/locale_impl.o ../lib/obj/GCC/ReleaseD/locale.o ../lib/obj/GCC/ReleaseD/locale_catalog.o ../lib/obj/GCC/ReleaseD/facets_byname.o ../lib/obj/GCC/ReleaseD/c_locale.o ../lib/obj/GCC/ReleaseD/c_locale_stub.o ../lib/obj/GCC/ReleaseD/complex.o ../lib/obj/GCC/ReleaseD/complex_exp.o ../lib/obj/GCC/ReleaseD/complex_io.o ../lib/obj/GCC/ReleaseD/complex_trig.o ../lib/obj/GCC/ReleaseD/complex_io_w.o ../lib/obj/GCC/ReleaseD/string_w.o   
> `.L5217' referenced in section `.rodata'
> of ../lib/obj/GCC/ReleaseD/locale_impl.o: defined in discarded section
> `.gnu.linkonce.t._ZNK4_STL9money_getIwNS_19istreambuf_iteratorIwNS_11char_traitsIwEEEEE6do_getES4_S4_bRNS_8ios_baseERiRNS_12basic_stringIwS3_NS_9allocatorIwEEEE'
> of ../lib/obj/GCC/ReleaseD/locale_impl.o `.L5275' referenced in section
> `.rodata' of ../lib/obj/GCC/ReleaseD/locale_impl.o: defined in
> discarded section
> `.gnu.linkonce.t._ZNK4_STL9money_getIwNS_19istreambuf_iteratorIwNS_11char_traitsIwEEEEE6do_getES4_S4_bRNS_8ios_baseERiRNS_12basic_stringIwS3_NS_9allocatorIwEEEE'
> of ../lib/obj/GCC/ReleaseD/locale_impl.o
> ... etc. ...
> That is, when linking the libstdlport_gcc.so.4.5 there is some linker
> problem which I have no clue about what is wrong. Any ideas here?
> When using the GCC 4.x series, the build stops even earlier when
> encountering the first C++ file:
> g++-4.0 -D_REENTRANT -DGXX_INCLUDE_PATH=/usr/include/c++/3.3
> -fexceptions -ftemplate-depth-32 -I../stlport -Wall -W
> -Wno-sign-compare -Wno-unused -Wno-uninitialized  -O2 -fPIC
> dll_main.cpp -c -o ../lib/obj/GCC/ReleaseD/dll_main.o
> ../stlport/cstdio:111: error: '__std_alias::vsnprintf' has not been
> declared
> As Debian does ship OpenOffice.org, I'm wondering what my mistake in
> building OOo is.
> Does anybody have any idea? I do not care which GCC version I have to
> use, as long as I can successfully build OOo.
> -- 
> Stefan Bellon
	Go to this url :

and download the deb and install that's  what I did and it worked fine..

I'm running Sarge.  

That is unless you want to keep the 'headache' or just want it to work..

Hope this helps,

Reply to: