[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

system recovery

Greetings all,

I maintained a LAN web/mail server and today the server does work properly:

The server is using the Etch, and I will do a 'apt-get -f
dist-upgrade' each day and make some adjustments if needed, everything
looks fine yesterday.
Today I performed again the dist-upgrade seems nothing is wrong except
the procedure seems hanged while configuring a package, so I manually
interrupt it (CTRL-C) and tried dist-upgrade again, but it recommends
to do 'dpkg --configure -a' first, I of course obeyed, the procedure
hangs again on some package (takes unusually long time, but I was
doing the job remotely and I am not 100% sure if it was still
performing the job, the package was gnome-something may be), I tried
to CTRL-C but not work, CTRL-Z did, and I decided to reboot the
machine, that starts the nightmare.

I then cannot ssh to the machine any more so I decided to go there and
check the box physically, it hangs on some reboot procedure, so I
reboot the box manually, during the boot procedure, errors like:

'45xx-xxx: log_xxxx (command not found)' appears repeatly, they
apparently comes form the /etc/rcx.d/* -> /etc/init.d/*), worse, APT
utilities does not work completely, the /var/lib/dpkg/available is now
full of '\0', and I followed some procedure on a website to recover
it, dpkg does not complain with available any more, dpkg says execute
configure script error, I can start daemons like apache on that box,
web is still OK for remote users, but 'telnet localhost 80' will time

I am wondering what kind of problem it is likely to be? How can I recover it?
Many Thanks and any suggestion is appreciated.


Reply to: