[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Xaralx on testing



Hi,

Recently, I upgraded my machine to testing from sarge. On sarge, xaralx
(version 0.7 rev. 1764) would run without any issues. But after the upgrade,
it segfaults.  Removed ~/..XARA-XTREME-WX-xaralx-mas and
~/.XaraLXFilters/. Still the same problem. Ran strace on xaralx and here
are the last lines of the ouput:

....
fstat64(6, {st_mode=S_IFREG|0644, st_size=909044, ...}) = 0
mmap2(NULL, 935588, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 6,
0) = 0xb6fea000
mmap2(0xb70c4000, 20480, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 6, 0xd9) = 0xb70c4000
mmap2(0xb70c9000, 22180, PROT_READ|PROT_WRITE,
MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0xb70c9000
close(6) = 0
mprotect(0xb70c4000, 12288, PROT_READ) = 0
gettimeofday({1164678795, 243914}, NULL) = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
rt_sigaction(SIGFPE, {SIG_DFL}, NULL, 8) = 0
rt_sigaction(SIGILL, {SIG_DFL}, NULL, 8) = 0
rt_sigaction(SIGBUS, {SIG_DFL}, NULL, 8) = 0
rt_sigaction(SIGSEGV, {SIG_DFL}, NULL, 8) = 0
rt_sigaction(SIGFPE, {0xb781e790, [], 0}, {SIG_DFL}, 8) = 0
rt_sigaction(SIGILL, {0xb781e790, [], 0}, {SIG_DFL}, 8) = 0
rt_sigaction(SIGBUS, {0xb781e790, [], 0}, {SIG_DFL}, 8) = 0
rt_sigaction(SIGSEGV, {0xb781e790, [], 0}, {SIG_DFL}, 8) = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++
Process 3907 detached

Can someone point to me a solution for this problem?

Regards,

-- 
Sridhar M.A.                                 GPG KeyID : F6A35935
  Fingerprint: D172 22C4 7CDC D9CD 62B5  55C1 2A69 D5D8 F6A3 5935

Be security conscious -- National defense is at stake.

Attachment: signature.asc
Description: Digital signature


Reply to: