[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Writting on encrypted partion with Debian sarge reading with Knoppix

Hi Max,

Am Dienstag, 22. August 2006 18:02 schrieb Max Vozeler:
> Hi Rainer,
> On Sat, Aug 19, 2006 at 06:46:22PM +0200, Rainer Dorsch wrote:
> > What I did:
> >
> > On the Sarge side:
> >
> > modprobe blowfish
> > modprobe cryptoloop
> > losetup -k 256 -e blowfish /dev/loop0 /udev/mdisk5
> <...>
> > When it comes to knoppix now, I tried
> >
> > losetup -e blowfish256 /dev/loop0 /dev/sda5  # did not accept -k
> > parameter mount -t ext3 /dev/loop0 /mnt/crypto
> >
> > Then I got the error message:
> >
> > EXT3-fs: unable to read superblock
> > mount: wrong fs type, bad option, bad superblock on /dev/loop0,
> <...>
> This is probably because of the different default hash functions in
> "normal" Debian losetup (package mount) and the loop-AES patched losetup
> used in Knoppix. The Sarge losetup uses rmd160 to hash the passphrase,
> whereas the loop-AES patched losetup on Knoppix probably uses sha512.
> You can try to explicitly specify rmd160 with the -H option, like
> "losetup -e blowfish256 -H rmd160 /dev/loop0 ..."

I did specify the -H rmd160, but it did not change anything, passphrase was 
ok, but same error message, when I tried to mount the file system.

With losetup /dev/loop0, I got on Knoppix

/dev/loop0: [0011]:9556 (/dev/sda5) encryption=CryptoAPI/blowfish-cbc

On the sarge machine, which can mount the encrypted file system correctly, I 

silverboxy:~# losetup /dev/loop0
/dev/loop0: [000c]:6517 (/udev/mdisk5), encryption blowfish (type 18)

That looks different and I assume that is the reason why I can't mount it with 

Can I find out when mounted on the Debian system, what the right parameters 


Rainer Dorsch
Alzentalstr. 28
D-71083 Herrenberg
jabber: rdorsch@jabber.org
GPG Fingerprint: 5966 C54C 2B3C 42CC 1F4F  8F59 E3A8 C538 7519 141E
Full GPG key: http://pgp.mit.edu/

Reply to: