[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: mkinitrd question

Hugo Vanwoerkom wrote:

This is a long shot, but bear with me please.

I run a two-seater desktop with suspend2 in a custom kernel.

I use no initrd image.

But with suspend2 you can have a user interface showing you what is happening in either text of fb. Text is good enough for me (TM)

But on resume the user interface module must be present in an initrd image in order to show up.

So I am trying to create an initrd image with just 3 things in it that I have entered into /etc/mkinitrd/modules:


and those I have place in directory /lib/modules/

Then in / I run:

mkinitrd -k -o initrd.img

But the error that keeps occurring is:

FATAL: Module suspend2ui_fbsplash not found.
FATAL: Module suspend2ui_text not found.
FATAL: Module suspend2ui_usplash not found.


These are "user built" modules and not kernel built modules, they don't even have the right .ko extensions, how do you make an image that includes them?

Problem is that on a newer kernel you run yaird.

Have to tweak the /etc/yaird/Templates.cfg

Reply if you want details.

Then run yaird -o /boot/initrd.img

And then lilo.

It worked but only the first resume, not subsequent ones :-(

Haven't tried ydebug yet.


Reply to: