[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

painful accidental Xorg upgrade

Hello. I spent several hours this evening dealing with the
consequences of an unintended Xorg upgrade, and I thought it might be
worth reporting here in case others could learn from my experience.

The upgrade was unintended only in the sense that all I really wanted
to do was upgrade k3b:

  apt-get -u -t testing install k3b

But that upgrade took out my xserver completely (without a warning
that I saw at least) and so (obviously) X wouldn't start. When I
realized what was wrong, I tried to fix that with:

  apt-get -u -t testing install xorg

That done, when I tried to start X again, I ran into the same problem
as had been reported as Bug #390772. I tracked that down through the
Debian bug-reports database, and removed the line:

  ModulePath   "/usr/X11R6/lib/modules"

which had been carried forward into the new xorg.conf.

Even after this, though, X still wouldn't start. It complained:

  Fatal server error:
  could not open default font 'fixed'

After a lot of messing around, I managed to fix this by hand-editing
xorg.conf and adding to it, essentially, the contents of the directory
/usr/share/fonts/X11/ (in the "Files" section)---information which had 
somehow not made it into the auto-generated xorg.conf.

The next problem was that gdeskcal (a little app that I'm fond of)
wouldn't start, complaining about a missing gtk module. 15 or 20
minutes spent googling led to the solution for that problem---install
python-gtk2 (though that was not a dependency on the gdeskcal package).

So three or so hours later, I have a system that works nearly as well
as it did before I accidentally `upgraded' it. Hmmmmmm ...


Reply to: