[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Etch apt-get "dependency trap"

Douglas Tutty wrote:

> On Sat, Oct 28, 2006 at 09:51:53AM +0200, jdkaye10@yahoo.es wrote:
>> I'm in serious trouble here. I was upgrading from xorg 6.9 to 7 but my
>> problem is the usual one. Everything was fine until wajig reported that
>> the /usr/X11R6/bin directory wasn't empty. It suggested moving the files
>> somewhere else and then restarting the install. I did this and then all
>> hell broke loose. Redoing wajig install xserver-xorg aborted again with
>> dependency problems and suggested I run apt-get -f install, which I did.
>> That only made things worse. I am now completely stuck. installing,
>> reinstalling, holding, removing or any other operation using, apt-get,
>> aptitude, wajig all abort. Running apt-get check gives this:
>> --------------------------------------------------------------------
>> The following packages have unmet dependencies.
>>   gdm: Depends: xbase-clients but it is not installed
>> ------------------------------------------------------------------------
>> Running apt-get -f install gives this:
>> -----------------------------------------------------------
>> Unpacking xbase-clients (from .../xbase-clients_1%3a7.1.ds-3_i386.deb)
>> ... dpkg: error
>> processing /var/cache/apt/archives/xbase-clients_1%3a7.1.ds-3_i386.deb
>> (--unpack):
>>  trying to overwrite `/usr/bin/xgamma', which is also in package unicon
>> dpkg-deb: subprocess paste killed by signal (Broken pipe)
>> Errors were encountered while processing:
>>  /var/cache/apt/archives/xbase-clients_1%3a7.1.ds-3_i386.deb
>> E: Sub-process /usr/bin/dpkg returned an error code (1)
> What is wajig?  I only use aptitude.  Perhaps a cause of this could be
> using more than one package installer (wajig and apt-get).  I would
> suggest aptitude only.
> What is unicon and what depends on it?  What happens if you remove
> unicon and xbase-clients then install xbase-clients again.
> Doug.
Hi Doug,
No it wasn't wajig (another frontend for dpkg). I've used them all
interchangeably for years with no problems. Brad's solution worked
perfectly and now I'm happenly typing this with graphics from Xorg 7.1 and
a fully functioning Radeon 9950 graphics card with 3D capabilities.

My problem before was that I couldn't remove, install, purge, hold anything.
As Brad said, "apt was comletely wedged". dpkg -r was the solution.

Reply to: