[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

X not working, can't apt-get upgrade, and other problems (fwd)



A few days ago, X stopped working correctly on my laptop. Normally, it automatically goes to a graphical login, but it started just going to a prompt. I logged in as root and ran kdm, and it gave me the error "apm: disabled upon user request."

My friend suggested that I upgrade, but it stopped working because of errors with ntpdate. Now I still can't upgrade, but I'm getting different errors than I was last night: now I get 'No such file' errors for a few things and it also says "11 not upgraded" and "823 not fully installed or removed".

Then I tried apt-get remove ntpdate and got the error:
Package is in a very bad inconsistent state - you should reinstall it before attempting a removal.
terminate called after throwing an instance of 'std::logic_error'
 what(): basic_string::_S_construct NULL not valid
Aborted

And so then I tried apt-get install --reinstall ntpdate and got
Preparing to replace ntpdate ...
invoke-rc.d: initscript ntpdate, action "stop" failed.
dpkg: warning- old pre-removal script returned error exit status 6
dpkg - trying script from the new package instead...
dpkg: error processing /var/cache/apt/archives/ntpdate_1%... .deb (--unpack):
there is no script in the new versio of the package - giving up
invoke-rc.d: initscript ntpdate, action "start" failed.
dpkg: error while cleaning up:
 subprocess post-installation script returned error exit status 6
Errors were encountered while processing:
/var/cache/apt/archives/ntpdate_...i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

While I haven't been able to use X, I have tried to use ctrl-alt-F*, but whenever I do that, my machine seems to stop receiving keyboard input entirely.



Reply to: