[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: vmware installs won't run

On Tue, 3 Oct 2006 11:40:12 -0800
Greg Madden <gomadtroll@gci.net> wrote:

> I am running Etch. with 2.6.16 sources, doesn't require the ~any-any
> patch. After a recent upgrade Vmware no longer runs. It installs
> okay. I get an error message:
> "usr/lib/vmware/bin/vmware: /usr/lib/vmware/lib/libpng12.so.0/libpng12.so.0:
> no version information available (required by /usr/lib/libcairo.so.2)"
> I googled the error message and actually found a response from a
> Ubuntu user

Oh, don't listen to them ;-)

> " Copy /usr/lib/libpng12.so.0 to /usr/lib/vmware/lib/libpng12.so.0/."
> this eliminates the error message but Vmware doesn't run.
> Any vmware users seeing similar results? 

This is the result of a recent dbus upgrade. The solution is to either
remove libdbus-1-2 from your system or preload libdbus-1-3. I took the
latter option, adding the following line to the script
/usr/local/bin/vmware (vmware is installed in /usr/local):

    export LD_PRELOAD=/usr/lib/libdbus-1.so.3



Reply to: