[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

cups configuration

Dear Friends,

I am a long time user of sid.

I frequently have trouble setting up cups properly 
again after an upgrade, particularly lately :).

I have a network of computers which all print to a single machine which has the printer installed on it.

I am currently able to get the computer with the printer itself to print.

However the client computers are  not "discovering" the cups printer on the "server computer".

1) I have gotten the server computer to print. It is located at

	To get the main computer to print 
	I simply made sure that 
	/etc/cups/cupsd.conf had the line

Listen localhost:631

2) Then I tried to make it let others print to it with the lines
in cupsd.conf

# Show shared printers on the local network.
Browsing On
BrowseOrder allow,deny
BrowseAllow @LOCAL
BrowseAllow 192.168.*.*

# Default authentication type, when authentication is required...
DefaultAuthType Basic

# Restrict access to the server...
<Location />
  Order allow,deny
  Allow localhost
  Allow 192.168.*.*


notice that i tried to specifically allow cause i was worried about the 
192.168.*.* syntax

3) I can then print normally on the server machine at
I then tried to configure the client machines.

For instance  I noticed in my latest install of sid on a  machine 
(after a hard drive failure) left my new machine without a
file, even though cups-client was installed :).

So i created one and  then i 

added the  line 


to clients.conf

Now I dont know what to set in cupsd.conf on this client machine.

I tried to change 
Listen localhost:631


but this did not work - cups would  not start.

Also For some time now the kde control panel has not been able to configure the cups client machine.



Reply to: