[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Xinerama issuse after upgrade to version 7



I'm curious if anyone else has experienced this and if it needs
reporting someplace.

I've been running Xinerama on a Matrox G550 for a few years.  With
this last xorg upgrade from 6.8.2 to 7.0.0 there were a few odd
things.

My card has two outputs -- one VGA and one DVI.  When I boot the VGA
is the main display (the DVI display is off until I start X).

After upgrading to 7, now when I startx the DVI display seems like the
"main" display, in that's where my window manager starts.  I could not
correct this in xorg.conf, and had to physically swap my cables to get
xinerama to work correctly.  Now my right hand monitor is the monitor
used when not running X, which is not really what I want.

I tried a bunch of different configurations but could not get it back
to how it used to be, with the left monitor being connected to the
VGA port and used as the main monitor for both console mode and when
X was running.


The other problem is after a reboot only one monitor starts.  The DVI
interface monitor stays in power save mode when X starts.  But, I've
found a trick to get it to start:

This is is my layout:

    Section "ServerLayout"
            Identifier      "Default Layout"
            Option          "Xinerama"      "on"
            Screen  0       "LeftScreen" 0 0
            Screen  1       "RightScreen" RightOf "LeftScreen"
            InputDevice     "Generic Keyboard"
            InputDevice     "Configured Mouse"
    EndSection

The only way I've been able to get both monitors to start is to
comment out Xinerama and my "right" screen.  Then the left monitor
(the DVI connected one) will come out of dpms mode.  That is:

    Section "ServerLayout"
            Identifier      "Default Layout"
            #Option          "Xinerama"      "on"
            Screen  0       "LeftScreen" 0 0
            #Screen  1       "RightScreen" RightOf "LeftScreen"
            InputDevice     "Generic Keyboard"
            InputDevice     "Configured Mouse"
    EndSection

Then I exit X and remove the comments then I can restart X and then
both monitors will start.

Anyone else having problems with getting Xinerama started or with the
left/right monitor configuration?



Here's more detail on my config:


#-------- Video Card-------------

Section "Device"
        Identifier      "Matrox G550[0]"
        Driver          "mga"
        Screen          0
        BusID           "PCI:1:0:0"
        Option          "AGPMode"               "4"
        Option          "HWcursor"
EndSection

Section "Device"
        Identifier      "Matrox G550[1]"
        Driver          "mga"
        Screen          1
        BusID           "PCI:1:0:0"
        Option          "AGPMode"               "4"
        Option          "HWcursor"
EndSection

#--------- Monitors -------------

Section "Monitor"
        Identifier      "SonyG500"
        HorizSync       30-107
        VertRefresh     50-85
        Option          "DPMS"
        DisplaySize     400 300     # 15.57" x 11.76
        # DisplaySize     362 273     # 14.25 x 10.75
EndSection

Section "Monitor"
        Identifier      "Dell21"
        HorizSync       30-107
        Option          "DPMS"
        VertRefresh     50-85
        #VertRefresh     50-80
        DisplaySize     400 300     # 15.57" x 11.76
EndSection

Section "Screen"
        Identifier      "LeftScreen"
        Device          "Matrox G550[0]"
        Monitor         "SonyG500"
        DefaultDepth    24
        SubSection "Display"
                Depth           24
                Modes           "1280x960" "1024x768"
        EndSubSection
EndSection

Section "Screen"
        Identifier      "RightScreen"
        Device          "Matrox G550[1]"
        Monitor         "Dell21"
        DefaultDepth    24
        SubSection "Display"
                Depth           24
                Modes           "1280x960" "1024x768"
        EndSubSection
EndSection


Section "ServerLayout"
        Identifier      "Default Layout"
        Option          "Xinerama"      "on"
	Screen	0	"LeftScreen" 0 0
# Note, after a reboot have needed to common out screen 1 below
# to get the second screen to start, and also comment out Xinerama
# That gets the second screen to turn on, then re-edit to work
# Mon Jul 31 07:00:12 PDT 2006
	Screen  1	"RightScreen" RightOf "LeftScreen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
EndSection






-- 
Bill Moseley
moseley@hank.org



Reply to: